1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Adding special characters in Windows 10 (w/o numeric keypad or Character Map)

Discussion in 'Off Topic [BG]' started by Killed_by_Death, Dec 17, 2018.


  1. New computer arrived last week & my old one never jived with a BlueTooth keyboard or mouse.
    The new one does, so I ordered a nice new keyboard & mouse, but the downside is the new keyboard is smaller & w/o a numeric keypad.

    In the past I did all the special characters with the NumPad:
    Alt+0233 = é
    Alt+0246 = ö
    etc.

    There's a trick to do those using UniCode, but unfortunately it doesn't work on most Windows applications. So far I've found it only works in Office applications, Character Map, or WordPad.

    Well, if I had Character Map up already, I'd just do it the old-fashioned way & copy it from there, but I'd like to do that a bit more seamlessly, maybe with some shortcut keys.

    I've still got my old keyboard here with the numeric keypad, so it would be possible to input the keystrokes, but my problem is recording them.

    For a moment I thought that the On-Screen keyboard was the way, because it has an option for a numeric keypad. However, you can only do one sequence of Alt+Number & it releases the Alt key.
    In order to do the sequence for ASCII codes the Alt key needs to be held down throughout the number input sequence.

    Yes, I realize there are programs out there to produce hotkeys, but I'd rather not have yet another application running in the background at all times.

    I did try one trick that is a registry edit to the input method of the current user & found the Hot Keys.
    The tip didn't work, but it did get me thinking that Hot Keys of the ASCII sequence could be imported to the registry.

    HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys

    There's quite a few in there already, but they've got something to do with international languages.
    I've tried the Input Method Editor & it seems the same.
    This is seeming more & more like the way forward, but I haven't got a clue how to use it.

    The new keyboard also won't have Home or End keys, which get frequent use.
    Any ideas?

    Yeah I know, buy a different keyboard, but...
    couldn't find one that was backlit with the features I wanted, & I already trust LogiTech.

    On the evening I decided to order the keyboard I had surmised I could use Unicode,
    ö = 00F6 (followed by Alt+X)
    Little did I know it only works in few applications, which I found out later :bored:
     
    BurnOut likes this.
  2. OldDog52

    OldDog52 Gold Supporting Member

    Jan 1, 2011
    Last edited: Dec 17, 2018
    Killed_by_Death likes this.
  3. Ah yeah, the touch-screen keyboard does the trick. Odd that the regular on-screen keyboard won't.
    Now if I can just figure out a way to get those End & Home keys back.

    Just found out today that BT mouse & keyboard won't wake up my computer, which is a drag.
    I went so far as to edit the registry so that "Allow this device to wake up this computer" selections were available, rebooted & still no dice.

    Apparently the BT radio gets cut completely off in Sleep mode.
    even when the "Allow the computer to turn off this device" is unselected for it
     
    OldDog52 likes this.
  4. OldDog52

    OldDog52 Gold Supporting Member

    Jan 1, 2011
    Have you checked Power Settings? (Lifted from an HP Support)

    “You can wake up the computer from sleep mode using a Bluetooth mouse by changing the power settings in Windows.

    Follow the below steps:

    Open the Keyboard control panel item,
    1. Click the Hardware tab, and then click Properties.
    2. Click the Change Settings button.
    3. Click the Power Management tab, and then verify that the Allow this device to wake the computer is enabled.
    4. Click OK, and then click OK again.”
     
    Killed_by_Death likes this.
  5. OldDog52

    OldDog52 Gold Supporting Member

    Jan 1, 2011
    Try Fn-Left and Fn-Right for Home and End.
     
    Killed_by_Death likes this.
  6. Yeah, I've set up the power management tabs, but I can see a red indicator on the keyboard when the computer is asleep & a key is pressed.
    The same indicator lights green when it's paired.
    I might ask Lenovo if I'm wasting my time, as it appears the radio is off, even when the setup says it should not be.
     
  7. Finally, a fix for the wake on BT.
    Got a new BIOS update from Lenovo earlier this week & now it wakes just fine!
     
    OldDog52 likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.