Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

AI cutting out ?

Discussion in 'Amps, Mics & Pickups [DB]' started by Bijoux, Sep 1, 2002.


  1. Bijoux

    Bijoux

    Aug 13, 2001
    Denver-CO-USA
    it seems like evry time I use my extension cab with my Acoustic Image the sound cuts off if I dig in too hard, it doesn't have to be too loud to do that. does anybody experience that? thank you.
     
  2. Chris Fitzgerald

    Chris Fitzgerald Student of Life Staff Member Administrator

    Oct 19, 2000
    Louisville, KY
    No such problems here. I do play at one place with "dirty power", which causes the amp to make static hissing noises (like television "snow") , but this only lasts for about 30 seconds before it evens out, and then it's fine.
     
  3. Chris,
    I had the same problem with my AI. I called Rick Jones at AI and he told me to spray contact cleaner on ALL the input jacks (even the ones I don't use) and then insert and remove a plug a few times while it still wet. I did that and the problem went away and has not returned.
     
  4. Chris Fitzgerald

    Chris Fitzgerald Student of Life Staff Member Administrator

    Oct 19, 2000
    Louisville, KY
    Bob,

    Thanks for the tip. I've heard people say to do that, but I never figured it would work in my case because the noise happens even when there are no cables plugged into the inputs (except the speaker cables of course...). Could be I'm mistaken, though.


    Bijoux,

    If you don't get any helpful responses down here, you might try trying the same topic up in BG. They've got a couple of "Techie" amp gurus up there who always seem to have an explanation for stuff like this. Anyway, good luck.
     
  5. Bijoux,
    I suggest you call Acoustic Image for help. They recently extended the warrantee on all AI products to 5 years AND made it retroactive for anything they have ever sold. My experience with AI and particularly owner Rick Jones has been nothing short of wonderful. I wish all companies were as responsive to their customers problems as is Acoustic Image.

    The phone number for AI is 919-598-3113

    Email: rick@acousticimg.com
     
  6. Bijoux

    Bijoux

    Aug 13, 2001
    Denver-CO-USA
    Thanks guys,
    I've been trying to make that amp work with my Realistic, the only way to do that is to use less bass and more mids,highs and brite and tilt back the amp, I am also using GT mic, and that is a big help, I will contact AI, thanks again.