1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Alembic F-1X noise troubleshooting

Discussion in 'Amps and Cabs [BG]' started by Lonnybass, Jan 5, 2012.


  1. Lonnybass

    Lonnybass

    Jul 19, 2000
    San Diego
    Endorsing Artist: Pedulla Basses
    Hi gang-

    I am having some trouble getting to the bottom of some noise that my F-1x is putting out via the effects RETURN jack.

    I have typically run my rack tuner in front of the Alembic into the RETURN to take advantage of its mute function, but I am noticing a bit of distortion through my midrange when the signal is patched through it.

    I've done some isolating of the rack with different wire-ups, different preamps and bypassing various elements of the system to try and pinpoint it, and the only time I can recreate the distortion is using the RETURN.

    In addition to everything else, also tried running the tuner through the FRONT of the Alembic to see if I could replicate the sound - nope, sounds perfect, no issues.

    I'm curious if anyone has any ideas what the issue might be here. Could it be an electrical component going bad? A tube issue? Something else?

    NOTE: I have already opened up the preamp to hit the jack with contact cleaner and I have also tried the old trick of recycling the jack 30 or 40 times to try and remove any corrosion that may have built up.

    Thoughts welcome - I would love to get to the bottom of this as soon as possible. Thanks!

    Lonnybass
     

Share This Page