Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Amp Buzzing/Humming-HELP!!

Discussion in 'Amps and Cabs [BG]' started by kelvinf, Oct 6, 2001.


  1. kelvinf

    kelvinf

    Oct 2, 2001
    Meridian,MS
    Hello All,

    I own a Peavey combo115 that i bought used a few weeks ago. Up until today i had no problems with it. Last night i was practicing and a loud pop sounded. Then the amp started buzzing/humming. At first i thought the jack on my bass was loose but it wasn`t. I disconnected the bass and turned all the knobs to find the source of the noise. The only thing that i found was when i turned the post gain knob the noise changed volume slightly. I have no idea what is causing this noise,but it`s driving me nuts. If any of you have any advice, i would be ever so grateful to hear it,THANKS!
     
  2. Bob Lee (QSC)

    Bob Lee (QSC) In case you missed it, I work for QSC Audio! Gold Supporting Member Commercial User

    Jul 3, 2001
    Costa Mesa, Calif.
    Technical Communications Developer, QSC Audio
    It doesn't sound like anything major (as in expensive to fix), maybe a broken connection or a minor component failure. But it's probably something you'd want a competent technician to take care of. At least you're in Meridian, so you can save on shipping!
     
  3. brianrost

    brianrost Gold Supporting Member

    Apr 26, 2000
    Boston, Taxachusetts
    A pop followed by hum and buzz sounds like a capacitor failed somewhere in the signal path.

    Unless you're experienced in electronics repair, it's time for a trip to the shop.