Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Amp/cab makes click

Discussion in 'Amps and Cabs [BG]' started by Peik, Mar 16, 2005.


  1. Peik

    Peik

    Dec 2, 2004
    Sweden
    Hey TBérs

    Small amp - cab question.

    My Eden WT550 makes a loud clik when I turn it off. I am really concerned about it, I have asked around and some say it is ok. I always turn down the volume to 0. The eq led flashes red once when I turn of like it gets overloaded.
    It still bothers me. Any one have the same problems?

    Other question is, the last two times I have unplugged the cab before turning off the power. Will this damage the hed/cab?

    Should I return the Head or live with it
    Hope somebody can help

    Peik
     
  2. popinfresh

    popinfresh

    Dec 23, 2004
    Melbourne, Aus
    My head does it too.. It's fine. As long as you turn your volume down so it doesn't spike when the volumes up, it should be ok.
     
  3. Peik

    Peik

    Dec 2, 2004
    Sweden
    Hey

    But thats the thing I turn the volume down everytime and it still makes the sound. Loud and trebly. I am worried about my speakers. Does yours do it with the volume down too?

    Peik
     
  4. Peik

    Peik

    Dec 2, 2004
    Sweden
    And what does spike mean explain?

    Peik
     
  5. Sutton

    Sutton

    Mar 3, 2005
    Plainwell, MI
    Well, couldnt you just unplug your cabinets before you turn it off then?
     
  6. popinfresh

    popinfresh

    Dec 23, 2004
    Melbourne, Aus
    Hmm, nope, mine doesn't do it when i turn the volume down.. I'm not too sure then.
     
  7. Peik

    Peik

    Dec 2, 2004
    Sweden
    Thats what I srated doing, but I wanted to make sure taht did not damage anything.
    Anybody know if it is a save way of doing it.

    Peik