Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

amp humming problem

Discussion in 'Amps and Cabs [BG]' started by spidey255, Jul 12, 2002.


  1. spidey255

    spidey255

    Apr 25, 2002
    hey. i have a guild "thunderbass" amp. i think it's about ten years old. i've had it here in my basement for about 4 months. this problem has only started happening a month and a half ago. in mostly any position of my bass i get this loud humming noise. i have to position it another way to stop it and it's really hard to play. i'm absolutely sure it's not my bass cause i got it checked out and there was absolutely nothing wrong with it. and it's not the cord cause i tried a whole buncha cords and it happens with all of them. i asked someone about it and he said it might be because i have a flourescent light across the room and it's interfering. is this the problem?
     
  2. CS

    CS

    Dec 11, 1999
    UK
    try the amp in other rooms.

    When I lived with my parents I had a little combo that hummed. After various punch ups with the vendor who couldnt find the fault, my bedroom was on the same mains circuit as the kitchen and the refridgerator or something was interfering with it.

    BTW it might be the light, can you change it for a bulb affair?
     
  3. JoelEoM

    JoelEoM

    Mar 11, 2002
    Lancaster, PA
    definitely check out the light. i cant play in my living room because we have these little flourescent bulbs that my parents put in the lamps, and i didnt know about them. i went to play one day, and all i got was a lot of 60 cycle hum. so turned off the lights, and it fixed the problem. all you have to do to figure out if it is the lights is turn them off. its that simple.