amp makes a loud pop when i turn it on

Discussion in 'Amps and Cabs [BG]' started by ross, Jul 7, 2000.

  1. ross

    ross Guest

    Mar 17, 2000
    its done this since i had it i was wondering if its a problem or what?

    save the trees ban john turner conklins
  2. RAM


    May 10, 2000
    Chicago, IL
    I looked in your profile and couldn't determine what setup you're using. Can you be more specific about it?

    One thing you may want to do, though, is to put it into standby mode (if you have this option) or turn the volume all the way down prior to turning it on.

    Some brands just pop like that, though. My old Trace Elliot (may it rest in peace) used to do that a lot. I bought it new and treated it very well. I called the distributor and they told me that it was nothing to be concerned about.
  3. ross

    ross Guest

    Mar 17, 2000
    its just a combo amp and i turned the volumne all the way down and it stills make one loud pop when i turn it on

    save the trees ban john turner conklins
  4. White_Knight


    Mar 19, 2000
    My Crate BX-100 makes a "pop" when turned on (though it's not very loud). After that it's dead quiet, though. Ditto for my Crate BX-15. What brand of amp are you using? Every Crate (and most Peavey's that I've used) that I've ever used do that when they are turned on. The only amps that I know of that don't are amps with a relay in them (such as Hartke, where the actual amp doesn't turn on until the switch has been in the "on" position for a few seconds). I suspect it's normal, you could always contact the manufacturer to be sure though.
  5. ross

    ross Guest

    Mar 17, 2000
    i am using a no name brand called starford

    save the trees ban john turner conklins
  6. Dolan


    May 23, 2000
    Vienna Md
    I have owned a few amps that have done that also.Annoying it can be but is normal in some amps.I think it has something with stored voltage in capacitors?Correct me if I am wrong here guys.

  7. JimM


    Jan 13, 2000
    Northern California
    My old acoustic amp used to do that all the time,but it didnt do it when plugged into a different speaker(same 4 ohm,1x15)it did finally go out completely while had a loss of high frequency for years before it finally went.
  8. i used to have a loud, annoying pop too, but my mom divorced him.

    sorry, i totally stole that joke. seriously though, in the manual for my swr combo it says that a pop when turning the amp on or off is normal and will not harm anything. i don't like it anyway, so i switch my amp to headphone mode, which bypasses the speaker, before i turn it on or off. if your amp doesn't have this feature though, i just wouldn't worry about it.

    we hope you are ok.