Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Amp making strange noise: should I be worried?

Discussion in 'Amps and Cabs [BG]' started by ss81, Oct 28, 2005.


  1. ss81

    ss81

    May 29, 2005
    Last night at the start of band practice, I turned on my peavey t-max and it immediately started making these weird grumbling noises that almost drowned out the sound of my bass, and the speakers were moving around an awful lot. Changing between the two channels didn't affect it at all. It did stop when we tried deactivating the active switch but this may have been coincidental. It then randomly started up again and stopped when I pushed all of the eq sliders down. It didn't do it again for the rest of the evening, but I'm hoping this isn't a sign of serious trouble. Has this happened to anyone else? Is my amp going to die?
     
  2. ESP-LTD

    ESP-LTD

    Sep 9, 2001
    Idaho
    It might be as simple as an input jack, bad cable, or battery in your bass. If you can disprove those, then yes, I would be worried.
     
  3. try some wd-40 on the eq, as you say it stopped and started when you moved the sliders, could be just dirt in 'em...
     
  4. Not WD-40, get contact cleaner....

    See if the amp does that when there's nothing connected to it. Try a new cord. Try a new bass, or plug in a guitar, just to see if it does bad things.

    It could be just a loose battery connection on the bass, a bad cord.

    Randy
     
  5. NEVER use WD-40 to clean pots.
     
  6. why not? - it always does the trick for me...
     
  7. Eric Moesle

    Eric Moesle Supporting Member

    Sep 21, 2001
    Columbus OH
    WD-40 leaves a residue that attracts more dirt and grunge after it is used. It will solve your immediate problem, but create long lasting headaches. Contact cleaner does not leave a dirt-attracting residue.
     
  8. Exactly. Plus WD-40 is electrically non-conductive so it's actually an insulator.