1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Amp Repair BA 500

Discussion in 'Amps and Cabs [BG]' started by jarred m, Nov 7, 2019.


  1. jarred m

    jarred m

    Nov 7, 2019
    Hi Guys, starting a reapir job on my BA500 Ampeg.

    Here is a couple pictures

    can anyone 20191107_112424. tell me what the circular thing is in the head stock
     
  2. Good grief! That sir is the power transformer. May I humbly suggest that, with your level of knowledge, you put it back together before you make a cheap repair into an expensive or impossible one! :(
     
  3. jarred m

    jarred m

    Nov 7, 2019
    Amp has been down for bout 2 years . tryna trouble shoot
     
  4. Kriegs

    Kriegs Peace

    Feb 14, 2018
    MA/ RI area
    It's a toroidal power transformer. If you had to ask that question, please listen to @BassmanPaul 's advice :thumbsup:
     
  5. jarred m

    jarred m

    Nov 7, 2019
    thats not the problem. looks like the attenuater is bad. im getting signal through one speaker
     
  6. jarred m

    jarred m

    Nov 7, 2019
    tubes seem to be ok flashing in and out. is there enough current coming through?
     

    Attached Files:

  7. They are not tubes they are protection lamps for the high range driver. Just what is that amp doing/or not doing?

    P.S. Welcome to Talk Bass where men are men and sheep are nervous!! :D
     
  8. jarred m

    jarred m

    Nov 7, 2019
    its not producing sound from speakers. im not quite sure how to set up both speakers.
     
  9. ec2bass

    ec2bass Supporting Member

    Nov 3, 2019
    Texas
    You have received some very good advice. If nothing else be careful and please understand that with tubes there can usually be very high DC voltages (upwards of 300 VDC) sitting in capacitors if they have not been bled down. That's even with the AC power detached.
     
    Last edited: Nov 7, 2019
  10. jarred m

    jarred m

    Nov 7, 2019
    i have one speaker working but no enough for the other one
     
  11. jarred m

    jarred m

    Nov 7, 2019
    First time at this . so i apologize for my not understanding
     

    Attached Files:

  12. arbiterusa

    arbiterusa

    Sep 24, 2015
    San Diego, CA
    The amp does not have or use tubes. There is nothing in there you can fix. There are, however, plenty of ways you can destroy the amp, kill yourself, or both. Close that thing back up and take it to a shop.

    I'm not going to give you any further advice because you don't know what you are doing, and not knowing what you are doing when you're working with high-powered electrical devices can kill you.
     
    okcrum, BassmanPaul, Avigdor and 3 others like this.
  13. sawzalot

    sawzalot Supporting Member

    Oct 18, 2007
    @jarred m My suggestion: stop working on this thing before you seriously hurt or kill yourself. You are dealing with a huge amount of power that can be very dangerous. Failure to follow this suggestion may be fatal. Please take this to a qualified tech.
     
  14. jarred m

    jarred m

    Nov 7, 2019
    Got it guys thank you
     
    Aqualung60 and staurosjohn like this.
  15. TheReceder

    TheReceder

    Jul 12, 2010
    Mn.
    Props Jared... it's not easy sometimes to realize that you might be in over your head. I've got close to 25 years working on aviation components and even with that experience I typically won't work on amps without a schematic, the proper bench, or the needed test equipment.

    I didn't make that decision from doing anything smart.... I've blown up one to many pieces of gear by not taking the advice the gentleman above gave.
     
  16. jarred m likes this.
  17. ChronicPyromaniac

    ChronicPyromaniac

    Jan 25, 2001
    This amp has a speaker out, does it not? Does it work with an external speaker cab?
     
  18. Guitarist just had the same problem with his old peavey combo. Replaced all his tubes, turns out there was a bad "transistor" (I did the quotes because I'm not exactly sure if that's what it was. It started with a T though). Took it to a shop. They told him what the problem was, and repaired it in a day.
     
  19. Button that thing up ASAP before we all read about you in the Memoriam forum!
    take it in to a Qualified Tech and tell him what it is and isn't doing. This type of thing isn't something you should be trying on your own
    with your skill level! RTS
     
    Clutchcargo and agedhorse like this.
  20. elgranluis

    elgranluis Supporting Member

    Feb 14, 2003
    El paso, TX

    Ok , so from your pic , only one speaker works (100%?) but not the other one ?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.