Ampeg B2R combo is broken!Whats wrong?

Discussion in 'Amps and Cabs [BG]' started by cecile, Sep 23, 2004.

  1. I just bought a 2 year old B2R combo with 15" speaker about 2 weeks ago. About 3 days after I bought it, I noticed the there was something wrong with it. Sometimes when I play it will just cut out. When it cuts out there will be a faint sound of my bass, no sound at all, or a faint sound of my bass with distortion. Whenever I slap really loud (when it's not working) you'll hear this big boom (as if your turning on an amp) and sometimes the sound will come back on and sometimes it won't. It only messes up for a minute and then it does it again. I've tried different basses & cords but nothing helps. I took it to be fixed but they couldn't get it to cut out, and they couldn't find anything wrong with it. 2 days after I got it back, it started again. I'm going to take it to a different repair shop in the next few days, but before I do, does anyone have a clue what could be wrong with it? Thanks
  2. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    Sounds like a classic bad connection. Lots of places for that to happen, so I won't even attempt to guess where.

    Intermittent problems are the worst to check on.

    That unit at 2 years old should be under warranty......I hope you are not paying for the repair attempts.......
  3. I have the 4 X 8" version and had the same problem. In my case the input jack was the problem. I had my repairman install a Switchcraft (which took a little doing since it is different that the stock jack) and I've had no more problems. The total cost was $32.