Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg BA210 bass combo

Discussion in 'Amps and Cabs [BG]' started by matt007, Jun 11, 2003.


  1. matt007

    matt007

    Jun 11, 2003
    Hi

    When I turn off my BA210 combo I get a pop noise (normal), but followed by a whushing squeak noise from the speakers and horn. The volume is turned down before turning off. I never have heard a wushing squeak noise from these amps before when turned off? Just my own BA210 combo.

    Has anyone heard this wushing squeak noise from their BA210 combos when turning them off? The pop noise I am familar with, and I know is normal because there is no shut off relay

    Confused, need advice or input
     
  2. the pop noise is not really normal...


    be sure to have your bass plugged in,and the amp to be plugged in,especially if it's active!


    I think maybe the squeak noise may have something to do w/ your E.Q...


    Sorry,I dunno what im talking about

    -Jon:oops:
     
  3. philthygeezer

    philthygeezer

    May 22, 2002
    When I turn off my BA210 I get a pop noise too.

    Do you get a a little 'boiing!' sound when you turn the power switch ON?
     
  4. wow, i thought i was alone, this happens to me all the time. I also get a wierd digital distortion without the distortion on, and it has a hum that is incredibly loud, and the effects are horrible. I hate this amp :(

    -Ryan :bassist: