Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg Headroom.

Discussion in 'Amps and Cabs [BG]' started by fast slapper, Jan 7, 2002.


  1. fast slapper

    fast slapper

    Dec 11, 2001
    Fresno, CA
    Has anybody else had this problem before? You got your Ampeg head and after a year it seems to lose volume little by little, and it starts to clip earlier and earlier. I have a B2R and the first day I compared it with a SWR Bass 750, it definitly had more guts! Now there's no comparison, the 750 is now much louder.
     
  2. EString

    EString

    Nov 20, 2000
    Los Altos, CA
    You must be getting really old.
     
  3. Hategear

    Hategear Workin' hard at hardly workin'.

    Apr 6, 2001
    Appleton, Swissconsin
    Seriously think about getting something new.

    My amps and cabs always sounded best when they knew I had just looked at something else! Anyone else notice that?
     
  4. I've noticed it to a lesser extent...I think it might be more to do with becoming more comfortable with the amp's total sound, that it kinda drifts off in the background (ie you almost blank it out to a certain degree 'cause you're so used to it).

    Maybe...

    There have been situations though where i've experienced SS amps losing headroom over time, but generally it's years years years decades.
     
  5. I KNOW WHAT YOU MEAN, I THINK THAT YOU MAY NEED TO LOOK INTO NEW TUBES...:cool:
     
  6. No power tubes in either of those amps.