1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg PF-20T 60Hz grounding hum

Discussion in 'Amps and Cabs [BG]' started by focusbob, Mar 6, 2019.


  1. focusbob

    focusbob

    Jan 28, 2019
    I just received my new Ampeg PF-20T and it has a loud 60Hz type hum that goes away when I touch my strings or other instrument metal pieces. I've tried various instruments to no avail. Is this a known issue? Is mine particularly defective? Thanks!
     
  2. agedhorse

    agedhorse Supporting Member Commercial User

    Feb 12, 2006
    Davis, CA (USA)
    Development Engineer-Mesa, Product Support-Genz Benz
    Try a different bass, this is a classic symptom of a bridge that's no longer bonded to the signal ground within the bass.

    You are operating your amp on a grounded power circuit?
     
  3. focusbob

    focusbob

    Jan 28, 2019
    I am (grounded power circuit). I have tried 5 basses and 2 guitars... (also, these instruments do not exhibit 60Hz hum with other amps).
     
  4. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Apr 18, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.