Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg SVT-100 info/pics

Discussion in 'Amps and Cabs [BG]' started by Corwin81, May 14, 2003.


  1. Corwin81

    Corwin81

    Mar 18, 2003
    Ames, IA
    I've got a SVT-100 chassis coming soon to restore. It's got 4 6550s and 3 12AX7s I think(the schematic from Ampeg should be here tomorrow or Friday).
    I was wondering if anyone had one or had pics of one because I'd like to build a head cab like the original.
    I think it's MTI era.

    And any other info on it would be appreciated.
    Thanks! :bassist:
     
  2. Corwin81

    Corwin81

    Mar 18, 2003
    Ames, IA
    bump.

    anyone??
    pics of similar(early 80s MTI) era Ampegs?
     
  3. denn550

    denn550

    Jul 3, 2008
    Hi Corwin

    I just picked up an svt-100 thats not working. Would you be able to send me a copy of the schematic? Id be willing to help you fix it if you need help as well.

    Regards
    Dennis
     
  4. Surely he has fixed it in 5 years.:D
     
  5. denn550

    denn550

    Jul 3, 2008
    whoops.. didnt even realize the date.. Ill post again thanks!
     
  6. Corwin81

    Corwin81

    Mar 18, 2003
    Ames, IA
    Haha, yes it's fixed, and I gigged with it yesterday for the first time as a guitar amp for my church's 4th of July event. I pulled 2 of the 6550s so I could crank it louder through my Kustom 4X12.
    I've used it for bass a couple times and it works well for that too. It's basically a Marshall JCM800 2203 based amp. Just a few component differences in the preamp.
     
  7. patch12173

    patch12173

    Apr 12, 2011
    My SVT 100 is I believe in need of repair. Tubes or caps or something. She is or seems to be really quiet. I my get a new set of tubes to try that first and go from there. Corwin81, if you can share the schematic that would be great! Pm me if you can help.