Ampeg SVT-2 Pro Preamp Repair

Discussion in 'Amps and Cabs [BG]' started by Grimm, Sep 2, 2003.

  1. Grimm


    Dec 6, 2002
    Atlanta, Ga.
    I know I've seen this before, but had no luck trying to find it in the archives...

    Someone here mentioned that a repair was available to fix preamp distortion in SVT-2 Pro amps- something about a $5 capacitor or something similar...

    Could you guys let me know what exactly the repair is? I'd like to have it done...

    Also- anyone know of a good Ampeg tech in Atlanta?

    Thanks in advance for your responses...
  2. Grimm


    Dec 6, 2002
    Atlanta, Ga.
  3. jusplayinmybass


    Apr 17, 2003
    Conyers, Ga
    Keith McMillan Instruments, SIT Strings, Accugroove Cabinets
    I'm in Atlanta too. I want to get my SVT 2 Pro looked at by a tech for 2 issues I have. One is that ever so often, I hook it up, and get no output till I plug a 1/4" plug into all the jacks on the back. Then it works fine. I think it's something in the preamp. And I get serious clipping out of the preamp.

    I hear whatever you do, don't take it to Wizard. It will take forever. B Easy

  4. Grimm


    Dec 6, 2002
    Atlanta, Ga.
    Yes, I've heard that before-

    Bakos might be able to do it-

  5. notanaggie

    notanaggie Guest

    Sep 30, 2003
    The no sound deal is a problem with older ones in teh "new" type. Some of the older jacks have a through connection that air pollution messes up...

    The jacks can be cleaned and some form of contact lube put on, use WD40 if no better is available, to block the crap from corroding the jack plating.

    If you do the WD40 thing, don't get it sprayed all over the inside of the unit.

    New ones from the last few years seem to have a better plating or jack, they don't do the no sound deal.

    I don't know about the $5 capacitor deal....or whatever.