Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg SVT-3 Guts Question

Discussion in 'Amps and Cabs [BG]' started by blipndub, Nov 11, 2004.


  1. Can anyone identify the part below and let me know if it's supposed to be attached at all four posts?

    I'm getting vibration-related distortion and I'm wondering if this is the culprit.

    [​IMG]

    Thanks

    Here's a pic of it's overall location in the box
     
  2. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    That is the midrange coil, and it looks like it has been clobbered.

    The epoxy has pulled loose from the base, and at least one tap wire is broken off its terminal.

    Has UPS had that unit?

    There should be serious problems with the midrange control and switch........at least one setting should be fouled up.

    Since I dunno what else is loose, I'd say it looks like the unit took a big hit sometime, and there may be other problems besides that.

    I've never seen one torn loose like that before.......its a first.
     
  3. The amp has been "in family" since it was new (1996?) singer used it for acoustic guitar before selling it to me last year. It's gots lots of gig hours but no recent trauma that I can remember-think i'll get that coil fixed tho...
     
  4. BillyB_from_LZ

    BillyB_from_LZ Supporting Member

    Sep 7, 2000
    Chicago
    The coil looks like it was wound in 1994 (eighth week).

    Are you going to be fixing it yourself or taking it to someone?
     
  5. I'm tempted to take a shot myself. I've done guitar wiring but not amps, so it would be a learning opportunity for sure.