1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ampeg svt pro 4 peak light

Discussion in 'Amps and Cabs [BG]' started by mike620, Jul 12, 2014.


  1. mike620

    mike620

    Jul 7, 2014
    What's up guys. I just bought an svt pro 4 and the peak light (mute) is randomly engaging itself at low and high volumes. I tried turning the gain down,compression, volume, all of that but still the same problem. I'll probably end up bringing it to get checked out by someone but any help before hand would really be appreciated.
     
  2. jeffmaxwell

    jeffmaxwell Commercial User

    Oct 8, 2007
    San Diego, CA
    owner, Silver Hammer Designs
    The Graphic Eq/Mute jack on the back is probably dirty or has broken solder connection on the pc board. Try some contact cleaner in the jack and put a plug in and out a few times to see if that cures the problem. If not then you will have to have it serviced by a tech--the main board has to come out to resolder the jack. I have seen this problem many times.
     
  3. JimmyM

    JimmyM Supporting Member

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps, EMG Pickups
    I'm no expert, but could it be telling you that you have an intermittent tube?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.