Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg SVT2, new versus old

Discussion in 'Amps and Cabs [BG]' started by geddy2, Aug 29, 2004.


  1. geddy2

    geddy2

    Aug 29, 2004
    Southwest Michigan
    New guy here, hey all!
    I have been playing a hartke 3500 for the past 5 years, and it has been a good amp with no issues. I have a 6 month old Ampeg svt610, and love it. Recently I played through a new SVT2 at Woodwind Brasswind in Southbend IN. I fell in love with it. I have been told by a couple of bassists to try to find an older one though, because the new ones have some kind of circuit protection flaw. Is there any truth to this.
    Thanks
     
  2. inazone

    inazone

    Apr 20, 2003
    Colorado
    Ive been looking into ampeg for a few months now and havent heard that one before. As far as the 2-pro goes I would say the new one is as good as the old one....., but dont take my word for it.
     
  3. atoni

    atoni

    Jan 23, 2004
    Helsinki, Finland
    Endorsing Artist: Salo Guitars
    The protection mode problem was only in the first generation of the SVT2Pro. It required replacing a $5.00 circuit board that any authorized tech can do.

    The later generations of the SVT2Pro do not have this problem...
     
  4. geddy2

    geddy2

    Aug 29, 2004
    Southwest Michigan
    Thanks , exactly what I was hoping to hear.
     
  5. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    Actually, its even simpler. A small capacitor is added to the circuit per a service bulletin from back in 1997.

    Should be no problem even if it is an early one and even if it never had the service bulletin applied to it.