Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg SVT3-pro Biasing Mosfet Question

Discussion in 'Amps and Cabs [BG]' started by svtb15, Feb 22, 2006.


  1. svtb15

    svtb15 Commercial User

    Mar 22, 2004
    Austin,TX - McKinney,TX - NY,NY, - Nashville,TN
    I play it all. Whatever works for the gig
    Does anyone have the procedure to do the bias of the mosfets on an Ampeg SVT 3 pro.
    I year or two ago i was getting some background distortion at low volumes from the head. The tech concluded that it needed a biasing with the small micro pot on the inside of the amp chasis PC board by the heatsink, RIGHT BY THE 12AU7 TUBE. That seemed to fix the problem. It started again recently. I opened the unit and tried myself by moving in tiny bits while watching the voltage on a DVM. One way it get very distorted, the other way the amp seems like it may overheat quikly. I found a spot that was OK by going to distorion and backing the internal pot ever so slightly so it goes away.. Seems to have done the trick. Are there any Ampeg SVT 3 Pro experts that may have an answer of how to do it properly?
    My 1972 SVT is a breeze to do with the load resistors and test signal.with 2 DVMs . but the Mosfets on the SVT 3 pro i have no idea.
    Thank you in advance
     
  2. svtb15

    svtb15 Commercial User

    Mar 22, 2004
    Austin,TX - McKinney,TX - NY,NY, - Nashville,TN
    I play it all. Whatever works for the gig