Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Ampeg SVT3PRO problems

Discussion in 'Amps and Cabs [BG]' started by Beav, Dec 21, 2004.


  1. Beav

    Beav Graphics Whore

    Jul 17, 2003
    Middle Tennessee
    Designer: Beav's Graphics
    My head needs to be repaired and I'm not really sure what to do. Whenever it's on, for time to time there will be this crackling noise for about 30 seconds and then it will go away for a while (this is without anything plugged in). It's also uber distorted when I play. It's like someone is playing what I'm playing at about 1/2 volume, but with some raspy distortion. I think (and I've been told) it's a good change there is a leak in the power part of my amp, but I'm not sure so I'm posting it here. Do I need to send my head back to Ampeg or can I pay someone to fix it?
     
  2. Basspolizei

    Basspolizei Pseudo bass player/collector Gold Supporting Member

    Jun 23, 2004
    US
    Buy basses and lots of guns before it's too late! You have been warned.




    Depends. Is it new enough to be covered under the worlds best warranty (5 years with receipt)? If so, get it to a repair shop authorized by Ampeg. If not find your area's most qualified repair shop and get it checked.
     
  3. Jerrold Tiers

    Jerrold Tiers

    Nov 14, 2003
    St Louis
    Sounds like either the tube power supply or the bias, can't tell from here.

    If you have the original sales receipt (even if you aren't original purchaser) and it was bought originally within the last 5 years, factory or an authorized repair outfit can fix it under warranty.