Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Annoying Clicking Problem

Discussion in 'Effects [BG]' started by BassGod, Feb 15, 2005.


  1. BassGod

    BassGod

    Jan 21, 2004
    I love my Morley Pro Series II wah. It sounds great, but there is one problem: whenever I turn it on, I get a clicking noise going through my amp. It's endlessly annoying, especially if I use delay, because it delays the clicking! This also happens, to a lesser (and much quieter) extent with my distortion pedal. Does Anyone know how I can fix this? I'd rather not pay for a repair, and I don't even know if music stores repair pedals.

    Thanks,
    Graeme :bassist:
     
  2. Tecx

    Tecx Radio Rock Leads To Sterility

    Jun 9, 2002
    Halifax, NS, Canada
    Many mechanical bypass pedals do this... Its a sad thing, but true... My frostwave blue ringer did it, so I put it in a buffered bypass loop (Boss PSM-5). Solved the problem...

    Alex

    p.s. the problem is caused by the switch storing a capasitance...

     
  3. BassGod

    BassGod

    Jan 21, 2004
    So this is a problem that can't be repaired? I was hoping it would be some sort of grounding problem.

    I mean, it's not really that bad, but what worries me is that I will be back in the studio recording soon, and I fear that when I'm recording my bass tracks and I engage the wah, the clicking noise will end up on the CD.

    Graeme