1. Please take 30 seconds to register your free account to post, make friends, earn reward points at our store, remove most ads and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Annoying Static humming

Discussion in 'Amps and Cabs [BG]' started by Crosh, May 26, 2001.


  1. A have a rather worrying problem with my amp, it's begun making a kinda static 'humming and fuzz' noise when i play through it. I still get the bass signal, but it has this real messy crackle to it.

    My amp is a 60w Laney combo, i've checked my leads and they seem to be fine, i've removed pedals from the equation and it still makes that noise.

    I'm a bit worried that my amp may be knackered - as i can't afford to replace it and have gigs to do ! Does anyone have any idea what could be causing this ? I sounds like a rattle in the casing a bit, but i've checked and can't find the source of the problem
     
  2. It could be a number of things. First thing to try is plugging it through another speaker and seeing if it sounds good or bad. Cause it may be a blown speaker. After that, you know if it truly is in the amp. At that point, someone who knows elecronics repair has to get into the amp guts. Could be a blown capacitor, could be a broken solder joint, almost anything.

    Just do as much as you can to narrow down the problem. Try a different cable, different bass, different speaker cab. See if it still does it with all the above swapped, trying each one at a time (only one thing changed from the original setup per test).

    Chris
     
  3. Thanks for your help, luckily i've just spent a 3 hour 'surgery' with it, and came to the bottom of the problem ;

    Blow Speaker Coil!!!

    I've borrowed a speaker for my gig on friday, and i'm looking to buy a replacement. I guess my next thread will be "whats a good 12" speaker cone ?"!!

    Cheers again