1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Anybody else Having issues with Carvin BX500?

Discussion in 'Amps and Cabs [BG]' started by k5koy, May 4, 2010.


  1. k5koy

    k5koy

    Oct 27, 2008
    Dallas, Tx.
    I sure am! I bought a combo unit from them a few months ago with the 2-10 cab, and it was awesome! Loved this thing. After just 3 weeks, I went to the studio for practice and turned it on and the protect circuit kick in. Fiddled with it for a bit trying to eliminate the cause and after a while it came on and functioned perfectly for the rest of the practice session. The next practice, same thing again. I called them and they said to send it in and they sent me a new one. Very good customer service with these guys! I got the new one and went on for a couple of practices with no issues, then bam, yesterday at practice, this new one starts messing up. Different symptoms this time. No protection circuit, but while I was playing along it just started slowly fizzling out and dropped power. I stopped playing and in just a few seconds it was back, so I went on playing and agian it farted and went away. Powered it down and back up again, and it was fine for a few minutes and started again. Continued to mess with it and it started working perfectly again for the remainder of practice. What are the odds of getting 2 bad ones in a row?.. Is it just a bad amp? Inherit to episodes? I cant imagine that I would ever feel confident enuff to gig with this now. Anybody else?

    Koy-West Texas

    **Robin Hybrid Freedom Bass
    **Carvin LB70 Walnut Bass
    **Warwick Corvette 4 Standard Hybrid
    **Fender Geddy Lee Jazz Bass
    **Tradition Fretless Bass
    **Takamine Hollow body Bass
    **Ibanez EW20ZW Electric/Acoustic
    **Ampeg B2R-Ampeg 410
    **Carvin BR510N Combo+Peavey Tour 15
    **Carvin PB100-15


    Carvin Club #156
    Texas Bassist Club #66
    Fender Jazz Bass Club #328
     
  2. DWBass

    DWBass The Funkfather

    Did it work fine anywhere else? Could be the circuits at the studio. Make sure those outlets are properly grounded!
     
  3. 5port

    5port

    Oct 14, 2009
    LI,new yawk
    Check the internal wiring in the speaker cabinet. This may require visual inspection. After a year of vibration connections loosen. If you can play the head into another cabinet for a full rehersal.
     
  4. diamondsplit

    diamondsplit

    Jan 13, 2012
    N.J
    I have had one since they first came out, I have 1x15 combo never had any problems there great amps for the price, There lightweight you might have got one that might have just had an unusual situation contact Carvin
     
  5. I would hope that he has contacted Carvin in the 4 1/2 years since this was active
     
  6. Damn! I've just read through yet another Zombie thread!!! This is getting tiresome!! :(
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.