Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Anyone's Ashdown ABM/EVO VU mtr crap out?

Discussion in 'Amps and Cabs [BG]' started by CaptainWally, Feb 9, 2006.


  1. CaptainWally

    CaptainWally Supporting Member

    Oct 21, 2000
    Sandy Eggo, CA
    Mine just barely moves now...

    Common problem?

    Likely diagnosis?

    Suggested fix?

    Thanks!!!
     
  2. Cougar207

    Cougar207

    Jun 17, 2005
    St. Charles, MO
    My Mag 300 did, twice. Not sure how to fix it. The solder joints look fine on mine, but its being sent back because the power amp died too. I'm hoping they just give me a new amp this time since about 9 months ago the preamp went out. :help:
     
  3. CaptainWally

    CaptainWally Supporting Member

    Oct 21, 2000
    Sandy Eggo, CA
    Follow up question:

    I've got the blue tolex variety. How the HECK do you even get into that thing? :confused:

    :)
     
  4. I've had it happen with my Mag and with my Peacemaker guitar amp. I frequently hear about VU meter problems with Ashdown, but it is the only problem I hear about consistently. The first time with the Peacemaker it was the bulb burning out. My tech complained a lot about the difficulty of getting in to fix it. The second time I didn't bother to fix it. When the Mag VU meter went out I made the same decision. Other than this problem with an extraneous feature I love the amps.
     
  5. THB_bassman

    THB_bassman

    Oct 11, 2005
    socal
    Pry out the 4 buttons on the top of the case, then you'll see the phillips screws that hold the amp in there.