Ashdown 4-way footswitch issues

Discussion in 'Amps and Cabs [BG]' started by Russ48, Dec 28, 2018.

  1. Russ48

    Russ48

    Dec 29, 2007
    Dudley, UK
    Hey there,

    I recently got hold of a fabulous used Ashdown ABM500 Evo III head and 4 x 10 ABM cab on eBay. I love the tone from it and especially the switchable features - valve, EQ, compression and sub-octave. I wanted to remotely control these features so I bought an Ashdown FS-4 to do so. However, when I plug it in, it lights up and turns on the sub-octave effect permanently - also using the 4 switches does nothing.

    Is there maybe an FS-4 specifically for my amp and I have the wrong one? Has anyone else had this problem? I did notice one other similar post regarding an FS-2 but there wasn't a solution presented.

    Any help would be great! The web seems a little thin on Ashdown footswitch stuff.

    Cheers,
    Russ
     
  2. Make sure all of the switches on the amp are in the correct position (out) or the FS4 won't work. If that doesn't work then either the FS4 or amp has a fault.
     
    Last edited: Dec 28, 2018
    Dasgre0g likes this.
  3. Russ48

    Russ48

    Dec 29, 2007
    Dudley, UK
    Hey, thanks for replying. Tried this. Still the same. I guess something is broken... I'll have the amp footswitch socket checked out.