Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

ashdown abm500 buzz problem

Discussion in 'Amps and Cabs [BG]' started by 513rocks.com, Mar 28, 2005.


  1. 513rocks.com

    513rocks.com Supporting Member

    Sep 22, 2004
    Mason, Ohio
    ive had an ashdown 500 for about 5 months. it has always had a little buzz to the tone. i just figured thats how they sound. ive heard people talk about how clean sounding they are and just thought they didnt know what they were talking about. when the amp is on, without a cord plugged in, it buzzes like crazy. when i plug it in the buzz stops. when i hit a note,it sounds fine untill i let the not sustain. at the end of the sustain the note starts buzzing real bad even at low volumes. it seems like this week its got alot worst. im taking it in to the place i got it brand new. he repairs them at the shop and told me he would let me borrow an amp till its fixed. does anyone know what might be wrong? ive tried dirrerent basses, cords, and cabs and the buzz is definitly in the head. i really hope this head isnt a lemon. ill post back as i go through this to let you all know whats up.
     
  2. Sounds like a grounding issue... in the amp? I would have suggested checking grounding on your basses, but I guess not. I don't think it's anything major... something might be loose or not properly grounded maybe.
     
  3. 513rocks.com

    513rocks.com Supporting Member

    Sep 22, 2004
    Mason, Ohio
    i dont know. ill find out today