1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Ashdown ABM500 EVO III is buzzing : normal?

Discussion in 'Amps and Cabs [BG]' started by gillento, Mar 12, 2009.


  1. gillento

    gillento

    Oct 15, 2005
    Luxembourg, Europe
    Nordstrand pickups
    Hi,

    I just got got a brand new Ashdown ABM 500 EVOIII RC.

    It produces a slight buzzing (not humming) through the cabs when running, wether some cable is plugged in or not, wether the mute button is pushed or not, even when the master post is completely turned down.

    I once had an EVO first generation, but I do not remember if there was abuzz with that amp.

    Might it be because of the fan?

    Has anyone noticed the same?

    Shipping the amp back will probably get expensive.
    So I am trying to avoid the "this is normal with this amp - answer" by the online seller.
     
  2. Handreas

    Handreas

    Nov 16, 2007
    Norway
    Mine has a slight buzz too. Nothing more than I'd expect from an amp though. However it does make a popping sound every now and again, which is VERY irritating. Also it's currently in the shop to fix a broken mute-button for the second time since I bought it (summer '08).

    I love the sound, but I'm not impressed by the quality...
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.