1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

B5R Help

Discussion in 'Amps and Cabs [BG]' started by elbeau, May 11, 2010.


  1. elbeau

    elbeau

    Feb 5, 2009
    Detroit MI
    I'll start off by calling myself a jackass for this one. When I got my SKB case I was a bit worried of geting the cables messed and tangled up so I looped the speaker output cable to an open hole, in this case the foot switch imput. Upon firing the amp up I noticed there was no sound but everytime I hit a string the OD light would flicker. After a few seconds I checked and realized I was sending a powered signal to my my foot switch. I quickly shut it down and pluged the speaker cable to my cab where it belongs. Everything sounds fine clean but I do not have OD anymore. Is this just a fuse or did I fry some of the inards? I'm afraid to take it in for the cost of repairs. Please help!
     
  2. This might sound very stupid but put a cable in and out of the foot switch input. Some years ago I had a similar problem and it somehow needed to reset itself per se.
     
  3. Rick Auricchio

    Rick Auricchio Registered Bass Offender

    You probably fried something in the footswitch circuit. Either you live without that function or take it for repairs.
     
  4. RickenBoogie

    RickenBoogie

    Jul 22, 2007
    Dallas, TX
    That's my guess too, the footswitch was fried. Shouldn't cost much to replace just that.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.