Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Bass 350 PA hum

Discussion in 'Amps and Cabs [BG]' started by dfarr, Jan 22, 2002.


  1. dfarr

    dfarr

    Feb 9, 2001
    Lakeland, FL
    I've been checking out you guys for a while now but this is my first post. Usually I can find what I'm looking for by doing a search but didn't really find an answer for this one.

    I have an SWR Bass 350 amp. Twice I've tried to go direct from the XLR out on the rear, once in a studio and more recently to the house mains at a club. Both times resulted in a loud hum from the monitors/speakers. The soundman at the club said he usually has that problem with "high-end" bass amps. Anyone familiar with this?
     
  2. Was your amp plugged into a properly grounded outlet before you plugged in the XLR cable?
    I had a similar situation where I connected the XLR before plugging the amp in and got a loud hum. When I plugged into the AC it resolved the problem.

    If that's not it, you may need to lift the ground. If the amp does not have a ground lift switch, you can purchase adapters specifically designed to lift the ground.
     
  3. dfarr

    dfarr

    Feb 9, 2001
    Lakeland, FL
    Yes, the amp was properly grounded. Sounds like the ground lift may be the solution. The amp doesn't have one but I think the ground lift adaptor you mentioned (plugs into the XLR cable) may do the trick. Thanks for the advice.
     
  4. jasonbraatz

    jasonbraatz

    Oct 18, 2000
    Oakland, CA
    i used my bass 350 lots of times for studio and live use, and never experienced such a thing. i'd check out the ground lift thing, and if that's not it i'd take it in.



    jason