1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Bass tone seems to be lost through pedals

Discussion in 'Effects [BG]' started by Keith Berrigan, May 8, 2018.


  1. Keith Berrigan

    Keith Berrigan

    May 29, 2015
    Am finding my bass tone is horrible when using my pedals, just went straight into amp bass sounds great, anyone know a cause or had similar
    I use, fender jazz, emg jvx pickups, into mark bass little mark it,
    Pedals, tuner, mxr compressor, boss oc 2, mxr envelope filter
     
  2. Bryan R. Tyler

    Bryan R. Tyler TalkBass: Usurping My Practice Time Since 2002 Staff Member Administrator Supporting Member

    May 3, 2002
    Connecticut
    It could be one of the bypasses of one of the pedals or one of your cables or a noisy power supply. The best way to figure this kind of thing out is to go one link in the chain at a time. Run your bass into a single pedal then out to your amp, then connect another, then connect another until you find the culprit.
     
    TheLowDown33 likes this.
  3. bearfoot

    bearfoot Suspended

    Jan 27, 2005
    Chittenango, NY
    I don't see this in your list, but every volume pedal except the Morley models are tonesuckers.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.