1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Bassballs (and/or EHX in general) power supply related noise

Discussion in 'Effects [BG]' started by monsterthompson, Apr 15, 2009.


  1. monsterthompson

    monsterthompson The Eighth Note Wonder Of The World Supporting Member

    Nov 25, 2008
    Hollywood
    I just noticed my Bassballs (brand new) has started to make noise. I'm getting a loud hum when the pedal is engaged. The switch and knob positions don't seem to have an effect on this.

    The issue appears to be related to the connection with the power supply jack. I'm running a VooDoo Pedal Power, and I've tried swapping the connectors and changing jacks to make sure it wasn't the supply. I noticed that when I put a bit of pressure on the power supply connector to push it firmly into the pedal housing, there are moments when the hum stops, but it comes back when I remove the pressue. I've found that I can position the power supply cable so that the pedal will engage quietly, but as soon as the cable is moved (even just slightly) the hum returns.

    I'm returning the pedal today for an exchange, but I wanted to know if anyone else had this problem and if it was particularly common.

    Thanks
     
  2. is it the small nano version? If so I have encountered this with a LPB-1 it seemed that the jack kept touching the ground some how and kept making a loop hum. I ended up taking it back.
     
  3. monsterthompson

    monsterthompson The Eighth Note Wonder Of The World Supporting Member

    Nov 25, 2008
    Hollywood
    yup, it is the nano. that sounds like we might be having the same issue.
     
  4. shinobi

    shinobi

    Nov 24, 2007
    Aichi, Japan
    i got a t-rex fuel tank jr. recently. when i powered my stereo electric mistress with it, there was a loud, low hum when the pedal was engaged. i sold the fuel tank and went back to daisy chains after that :(
     
  5. TheMutt

    TheMutt Guest

    Apr 28, 2007
    I have both a PP2+ and a nano Bassballs. Haven't had a problem with hum, but I'll be sure to update should the same problem occur.
     
  6. monsterthompson

    monsterthompson The Eighth Note Wonder Of The World Supporting Member

    Nov 25, 2008
    Hollywood
    The guys at the Mesa shop think it was a bad PC board and just a bad apple in the barrel. I returned it and they should have a new one for me soon. Sounded like this was a rare but not unheard of issue in their eyes.
     

Share This Page