1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Basslines Quarter Pound Jazz pickups prob?

Discussion in 'Pickups & Electronics [BG]' started by fretless bass, Apr 1, 2006.


  1. I recently installed a set of jazz basslines quarterpounds into my sx jazz bass. i had them done by my local music store. the only prob is there is a hum noise i know i will most likely always have but i think there is a ground or earth prob with the bass cause when i touch any metal part the hum noise is not as bad. i have brought the bass back to the store and he told me theres nothing can be done which is very annoying.

    Am i been told the truth here? or is it a bad job done by the store. i know u can get rid of the buzz when u touch liike strings/bridge and that so he must be just giving me the run around i guess. any suggestions here would be most helpful thanks.
     
  2. ebe9

    ebe9

    Feb 26, 2006
    South Africa
    What sort of lights are you playing under? I know I have had that problem in the past with cheaper pickups in my starter bass, but with basslines that should not be an issue.

    Another option is to get hold of some insulating material/paint and treat the electronics cavity to hopefully reduce the severity of the problem.
     
  3. anonymous278347457

    anonymous278347457 Guest

    Feb 12, 2005
    dont worry, i have the same problem on my MIM jazz, i think its shielding related
     
  4. dave120

    dave120

    Jun 27, 2005
    Central Florida
    Most basses with passive single coil pickups have this problem. Buy some copper shielding foil and shield the control and pickup cavities. Makes quite a difference in filtering out extra noise and hum, even with humbuckers sometimes.
     
  5. thanks for ur help i noticed when i touch any metal part on the bass the hum is 90% gone. so this may be a ground buzz prob. maybe the pups are not wired correct.
     
  6. mariner

    mariner

    Feb 18, 2005
    Front Royal, VA
    I have a Hondo P-copy and when I installed a set of quarter pounders in there, I had atrocious hum. A thourough shielding job and good soldering fixed it up. I still get a little hum as I increase tone, but it's not nearly as noticable.
     
  7. gafbass02

    gafbass02

    Nov 9, 2005
    cheltenham uk
    Exactly the same problem, ive put duncan quarter pounders on my Warwick FNA Jazzman and Streamer and have the exact same problem really, really bad hum that goes away with a loud click when i touch any metal parts, making them virtually unuseable through a lead, ive shielded them in the cavities and taken back to the shop etc, still no joy, anyone else got a proper fix for this?????, its the same on my Status energy six with stock pups, although not on my Ibanez BTB556
     
  8. fede162162

    fede162162

    Apr 6, 2006
    hi,don't worry, i have the same problem since i put the seymour duncan sjb2(hot) on my warwick.

    now the warwick sound better than before with mec, but it make a strong hum noise, more than my '81 ibanez!!!
     

Share This Page