Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

BIG problem, i just bought a used ampeg svt

Discussion in 'Amps and Cabs [BG]' started by bassguy187, Feb 5, 2001.


  1. bassguy187

    bassguy187

    Jun 27, 2000
    Nazo, PA
    alright heres the trouble, first off i play the svt through an swr goliath 2 4 x 10 and a crate 15 inch cab, i have it on the 4 ohm output selection, and when i play it always has this distortion in its a sort of rattling vibrating noise , i'm not sure why its doing it? do i need new tubes? please help me
     
  2. I think you need an expert to look at it. It's not necessarily tubes, could be crapped out tube sockets, maybe even dry solder joints, a myriad od possibilities.
     
  3. barroso

    barroso

    Aug 16, 2000
    Italia
    i've had the same problem on my second hand svt3 pro. i went to the technician and he tried to change the tubes but nothing changed. so he said it could be the mosfet final. infact it was right, he changed the mosfet for something about 100$ and everything went ok. i suggest you the same, go to a technician and ask for a check on the preamp tubes, if nothing seems to change it will probably due to the mosfet.
    good luck
     
  4. SVT's don't have MOSFET's - they're all tube. As far as the distortion goes, is it good tube distortion or something else? Have you tried knocking back your preamp volume?

    If something is rattling around, you may want to take it to a good tech who has experience with tube amps. How old is the amp?
     
  5. bassguy187

    bassguy187

    Jun 27, 2000
    Nazo, PA
    its in the late 80's or early 90's model.

     
  6. timv

    timv Supporting Member

    Jun 7, 2000
    Chandler, AZ
    If you put the head on the ground or off the cabinets that you are playing through, does it still make the sound. If it doesn't, it is something vibrating around. Could be preamp tubes, sockets, loose solder joints, or power tubes. If it doesn't do it setting on the cabinets, maybe you can get away with it like that for a while before you bring it in and have it looked at. But, you may want to have it looked at anyway so the problem doesn't damage anything. What model SVT is it?
     
  7. barroso

    barroso

    Aug 16, 2000
    Italia
    i know that original svt do not have mosfet, but the guy doesn't posted the model so i hoped my story could be of help.
     
  8. bassguy187

    bassguy187

    Jun 27, 2000
    Nazo, PA
    the model is the svt-cl it has no mosfet its all tube,
    3 preamp tubes and 6 6550's for powertubes.
     
  9. dont you're scaring me... i just bought a 2nd hand svt2-pro myself...
     
  10. bassguy187

    bassguy187

    Jun 27, 2000
    Nazo, PA
    how much did u buy it for?