Blowing breakers left and right...what da dillio?

Discussion in 'Amps and Cabs [BG]' started by JPJ, Feb 22, 2003.

  1. JPJ


    Apr 21, 2001
    Chicago, IL
    I'm currently using an SWR IOD and a Stewart 2.1, and have had problems blowing out circuit breakers like a mutha. I blew out one in my house when I first plugged the rig in a while back, and it happened right before a gig last week, causing a huge problem with the whole right side of the stage.

    I recently had the amp replaced due to other reasond, but it there a certain order in which you should plug your components in to prevent this from happening...similar to pre-amp on first and off last? Does it make a difference whether I plug my preamp power cord into a power strip first or second, and does it matter which order they're unplugged in?
  2. Petebass


    Dec 22, 2002
    QLD Australia
    Does the replacement amp have the same problem? I would have pointed towards a faulty amp but if they're both doing it I could be wrong.
  3. JPJ


    Apr 21, 2001
    Chicago, IL
    Haven't had a chance to try the new one yet, but I was wondering if there is an "order" that one should follow in plugging the components in...not that this would prevent a faulty amp from acting up and sparking/blowing fuses when you plug it in.
  4. Bob Lee (QSC)

    Bob Lee (QSC) In case you missed it, I work for QSC Audio! Gold Supporting Member Commercial User

    Jul 3, 2001
    Costa Mesa, Calif.
    Technical Communications Developer, QSC Audio
    Turn the power amp on last. That's to prevent a thump from going through to the speakers; if you're popping breakers, you've probably got a defective amp.
  5. Phat Ham

    Phat Ham

    Feb 13, 2000
    Power amps usually draw a boatload of current when you turn them on, so if you have multiple amps you don't want to turn them all on at the same time. Some amps have circuitry to prevent this current surge. But if you're using just one power amp it's probably the amp itself that's the problem.
  6. jokerjkny


    Jan 19, 2002
    NY / NJ / PA

    that's messed up. try usin' your own surge protector. and a electrician's suit while you're at it. :p :D
  7. JPJ


    Apr 21, 2001
    Chicago, IL
    I should be able to try out the replacement this week at practice. I was getting sparks while plugging it in...not to mention the blown breakers and virtually no volume from a 2000 watt amp. Just wondering if (in addition to turning the amp on last and off first) if there was an order in which the components should be "plugged in"? (where's the smiley face with the lightening bolts going through it!?) :D
  8. OK,this might seem like a stupid question, but are you plugging it in while it's on sometimes. Because if so, that would explain the sparks, and the blown fuses, and the compenent is immediatley sucking energy to power itself
  9. geshel


    Oct 2, 2001
    There's no "plug-in" order.

    Sparks when plugging it in (IF the power is off :) ) -> bad amp. No good at all.
  10. JPJ


    Apr 21, 2001
    Chicago, IL clarify for anyone else who has had, is having, or might have a similar problem...the sparks came while the amp was off. :p