blown eden metro

Discussion in 'Amps and Cabs [BG]' started by neptoon, Jun 23, 2002.

  1. neptoon


    Jul 25, 2000
    summerville, sc
    crap! i think i blew out the speakers on my amp at rehearsal last night. holy sounds like i'm running bass through a really bad distortion stomp box! mebbe i blew a tube, i have no clue. i don't even turn the thing up that loud. poo, man! i'm no tekkie at all...any suggestions?
  2. if you have a nother head just plug it in to see if it works and sounds the same if so then time to troubleshoot the spkrs.
  3. Golem II

    Golem II

    Jan 4, 2002
    Macon, GA, USA
    If you have an active bass, check the battery. That's always the last thing I think of, and that's why I am an idiot.
  4. some guy#2

    some guy#2

    Feb 3, 2001
    YES...a good suggestion!
  5. neptoon


    Jul 25, 2000
    summerville, sc batteries...i did run the line out of the head to a pa cab and disconnected the speakers on my amp....crystal clear...oh well, new speakers, it seems
  6. I'm assuming you know, but just in case... don't buy brand new... have your blown speakers reconed with REAL Eden parts. It will be much cheaper than buying new and will preserve the tone characteristics of your Eden.
  7. neptoon


    Jul 25, 2000
    summerville, sc
    thanks for the recommendation, man...but now for something odd...i plugged it in a moment ago to show the wife what it sounded like, so i could justify fixing the damn thing, right :rolleyes: and it sounded great. :confused:
  8. Man, that must be some wicked stuff you're smokin. :D Seriously though, now the tuff part starts... it's just like trouble shooting your car. Runs crap until you get it to the shop... then it runs great!
  9. neptoon


    Jul 25, 2000
    summerville, sc
    yeah, really....i dunno, man
  10. Gabu


    Jan 2, 2001
    Woodland Hills, CA
    That reminds me of the speaker in the left side door of my car. Once in a while it sounds like I am run it through a fuzz peddle, but I turn it off for a bit and then on again and it sounds fine.

    Try playing it for an extended period of time.
  11. if your not afraid to open the cabinet, just crack it open and check the wiring... and check all of teh cables starting w/ cord from bass to head... then continue on the chain... the problem will eventually present itself with an answer!
  12. Chuck M

    Chuck M Supporting Member

    May 2, 2000
    San Antonio, Texas
    There may be something loose moving around in the cabinet and it may have been touching one of the speaker cones. That will make it sound distorted.

    I recommend that you lay the Metro on its back, remove the speaker grill and then pop the speakers out one at a time for an inspection to see if something is inside that could touch the speakers.

    Good luck.

  13. in my studio monitor of a bass cab that was given to me my friend disected it and found a battery on the back of the magnet...

    it was given to me and my friend because they thought the speaker was blown...
  14. odie

    odie Supporting Member

    First off how old is it??

    Second thing call Eden. They are very helpful, small outfit and you may need to have them return your call, but they help you as much as they can.
  15. neptoon


    Jul 25, 2000
    summerville, sc
    it's three years old....i was just waiting for monday to roll around to call them up. this happened friday night, so...sheesh, anyway, i hope i get this thing figgered out. i took the speakers out, but i didn't see anything...
  16. Gard

    Gard Commercial User

    Mar 31, 2000
    Greensboro, NC, USA
    General Manager, Roscoe Guitars
    'toon -

    If there's anything I or BC can do to help, let us know! Sorry you're having trouble....


    Definitely call Eden and ask them what's up, they're VERY helpful!
  17. neptoon


    Jul 25, 2000
    summerville, sc
    hey, i did buy it from you guys :D what's the deal!? hee hee i'll call eden, and see if i can get a list of repair parts.....if so, i'll give you fellas a buzz. thanks, man