1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

brand new amp - terrible buzzing

Discussion in 'Amps and Cabs [BG]' started by jjl5590, Sep 24, 2008.


  1. jjl5590

    jjl5590 Banned

    Mar 28, 2008
    London, UK
    hi guys

    well, I just received my Warwick ProFet 3.2 amp today, but I am sad to say i am pretty sure it is faulty. It makes a terrible buzzing noise when connected to the cab, or to headphones, with or without the bass plugged in. There is nothing I can do to prevent it buzzing, it buzzes like crazy regardless of the volume or gain or EQ levels. I do not wish to open the amp up, as im pretty sure this will void the warranty, so I need your help as to what to do with it.

    many thanks guys
     
  2. Bassman7PM

    Bassman7PM

    Mar 13, 2006
    Chicago, IL
    Could be bad grounding. Try plugging it into another outlet in another room. Also, is it near a TV or CRT monitor? Simple troubleshooting techniques before shipping it back.
     
  3. jjl5590

    jjl5590 Banned

    Mar 28, 2008
    London, UK
    nope, ive tried various sockets, and it is not near anything that can cause electrical noise. i dont mean the amp is giving a little bit of feedback buzz, i mean it is really buzzing loud! when i plug in the bass, it is very very quiet, but the buzzing is so loud
     
  4. Jeff Scott

    Jeff Scott Rickenbacker guru.......... Supporting Member

    Apr 11, 2006
    I had the same issues with an Ashdown MK500; I returned it and bought a LMII.
     
  5. Navybass

    Navybass

    Mar 12, 2005
    Norfolk, Va.
    Warwick amps have never been known for their reliability. I remember I was looking to buy an older Warwick amp. I did some research on the amp and noticed that many different people were having trouble with that same amp, so I thought it just might be that particular model. I then looked up a few different models and noticed the same thing. Their reliability sucked.

    Needless to say I never bought the amp.
     
  6. jjl5590

    jjl5590 Banned

    Mar 28, 2008
    London, UK
    i did extensive review searches before i bought it, and appart from the odd negative one, all of them said it was great.

    where did you find your reviews?
     
  7. Mr_Dave

    Mr_Dave

    Mar 11, 2005
    Melbourne, Australia
    Employee - Basscentre Melbourne
    take it back to where you bought it - and use your warranty?
     
  8. Finally got an amp ey?

    Thats a bummer about just getting it and whatnot, when I brought My new amp home, the tube pre was broken, sent it away and had it fixed.

    So yeah, use the warranty
     
  9. Navybass

    Navybass

    Mar 12, 2005
    Norfolk, Va.
    It was an older Warwick amp, not the new ProFet's. I can't remember, it was a couple of years ago. Even the music store that I was going to buy it from told me they weren't that reliable which was why they stopped selling Warwick amps. They said that about 1/2 of them either came from the factory with problems, or came back within a year with a problem. The only reason they had that one in the store was because it was brought in for repair and in the mean time the original owner bought a new amp and basically told the store to just sell the Warwick.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.