Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Buzz/hum from warwick corvette, please help.

Discussion in 'Pickups & Electronics [BG]' started by Franklin, Nov 13, 2000.


  1. Franklin

    Franklin

    Nov 13, 2000
    I have this strange buzz from my bass. It usually fades away if I stand in a certain direction, but if I move around, it comes back. The bass was just bought in August and has been very well tended to. I tried plugging into another amp and got the same effect, so I'm assuming it is the bass and not the amp that is the culprit. I tried buying some fancy instrument cord, but it didn't help the buzz. I don't know if this buzz is something that can be fixed, or if I'll have to deal with it? It isn't too loud...When I play I don't hear it over the music, but when I stop playing I can definitely hear it. It gets louder if the volume on the bass is all the way up. Any suggestions/remedies would be appreciated!
    Thanks,
    Franklin

    [Edited by Franklin on 11-13-2000 at 02:55 AM]
     
  2. Oysterman

    Oysterman

    Mar 30, 2000
    Sweden
    Shielding, my friend. I think that should do it anyway... I have the same problem with my passive J-bass, but my active Yamaha does not give me that kind of buzz. My J has no shielding at all, but the Yamaha has.
     
  3. heymelbs

    heymelbs

    Aug 23, 2007
    Northern Iowa
    I'm bumping a really old thread, but I'm having the same problem that the initiator of the thread had. The answer was shielding, which means nothing to me. If this is the answer, then what is the fix? If not the answer, then what is the problem? I'm not using the bass because the noise is so annoying.