Buzzy ampeg

Discussion in 'Amps and Cabs [BG]' started by Davidoc, Aug 5, 2002.

  1. whether plugged into my QSC or my carvin's power amp (effects loop) my new ampeg SVP-pro buzzes. The one think I actually like about my carvin is that it's silent. The ampeg buzzes as long as it's on, even if the volumes off. The buzz stops when I switch the unit off, however. The bass doesn't matter, plugged in or unplugged, it's the same buzz.

    The buzz is goes up when the poweramp attentuation goes down- the only factor that affects the amount of buzz- and boy does it affect it! Wide open, the buzz is unbeably loud. With the control on about 1/4 there's a bearable, yet still easily audible buzz.

    It does this at every output I've put it through, and in different buildings. What seems to be the problem? Thanks!
  2. seamus


    Feb 8, 2001
    I bet it's defective, send it back and get a replacement.

    I had one that buzzed really bad right out of the box too, turns out it was defective as hell and had to go back. It just made a ton of noise with barely any audible bass signal.

    Though you might hear an audible hum (or noise) from the (cheaper) tubes, you shouldn't be hearing a buzz that interferes significantly with the signal.

    I use Electro-Harmonix tubes in mine and love em. Very low noise with sweet tone and harmonics. You shouldn't be hearing that buzz though. QC at Ampeg leaves a bit to be desired IMO.
  3. Thanks for the info. The buzz does not interfere with the signal, and it can't be heard over playing. It's just that when I'm not playing it is audible.

    Right now I'm ok with it, but if I ever need take advantage of the 850 watts and have to unatentuate the power amp, it will be intolerable. I'll look into sending it in if it continues to be a problem.