Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Cabinet problems?

Discussion in 'Amps, Mics & Pickups [DB]' started by Danny Adair, Jul 9, 2001.


  1. I have had a problem getting a decent sound out of my "electric" rig with my upright, and I wonder if the cabinet is to blame.

    Some background:
    Acoustic rig: 1987 Schmidt bass, Realist pickup, SWR Workingman's 12
    Electric rig: Aguilar DB659, Mackie 1400i, Eden 210T (awaiting delivery of an Acme Low B2)

    I have found that, while the eletric rig offers more volume, it has a more compressed, through-a-megaphone sort of sound. The electric rig also sounded unsatisfactory with my old GK 800RB head, which is what leads me to speculate that the Eden cabinet may be the primary culprit.

    Has anyone had experience with using a similar Eden cabinet with an upright bass? Does anyone have upright bass experience with Acme cabinets?

    Thanks for your help,
    Danny
     
  2. Bob Gollihur

    Bob Gollihur GollihurMusic.com

    Mar 22, 2000
    New Joisey Shore
    Big Cheese Emeritus: Gollihur Music
    I had an Eden 2x12 that wasn't too bad for URB, though I only used it a couple times- seldom need that much power. Eden does have that mid shy with some electric bass bumps in the frequency response. The combination of that with the Realist may not be so hot.

    The Euphonic Audio cabs I currently have are far more accurate and flat, and the midrange is much more pleasing and natural-sounding. I understand the Acmes, while much less efficient, are similarly full range and PA-like, so you may find them to do the job - at least based on what I've heard on the net. My Kern IP-777 preamp is really a great URB match, too; I had an Aguilar briefly but like the Kern better.