1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Calling all Tauras III users

Discussion in 'Effects [BG]' started by Blu bro, Oct 10, 2013.

  1. Blu bro

    Blu bro

    Mar 1, 2012
    For the record im hoping this is the right forum

    so just to let you know im rather precious about my tauras pedals but it seems no matter what you do to stop things happening you cant stop everything. Long story short a big ol keyboard case fell on my tauras pedals last night at band practice. it chipped a bit of the wood off the corner and i was cool with that.
    But.... i then plugged it in.

    now i usually plug the amp into the top jack (the Lo Z) but when i did i could only get the faintest sound from it with the amp up to mak and the volume on the pedals on max (even then you could only just hear it.).

    I checked leads and kettle cords, tried a different amp. I put the lead in the Hi Z input than to the amp, and it worked fine but had a quiet hum in it.

    Its fair to say i am a little worried as i live 5 hours away from the isolated in the world. i live in a city called Albany in Western Australia. And i dont really want anyone touching this thing unless they are an authorised servicemen.

    Has anyone experienced this problem? Really any input will be hugely appreciated.

    Seriously input please :)
  2. Stick_Player

    Stick_Player Banned

    Nov 13, 2009
    Somewhere on the Alaska Panhandle (Juneau)
    Endorser: Plants vs. Zombies Pea Shooters
    I'd contact Moog and see where their nearest authorized dealer, to you, is. They may even send you a replacement wood-piece.
  3. superdick2112

    superdick2112 Mile High Bassist Supporting Member

    Nov 20, 2010
    The Centennial State
    Sounds like you may have shorted a wire between the Hi & Lo outs. I have not taken my Taurus 3 apart yet, so I really couldn't say what the fix would involve, but a long drive to a good tech may be in your near future.
    One suggestion to try first - try reloading the latest OS from Moog via USB. If nothing else, this will also reset the "brain" of your T-3, & help you to determine whether the issue is hardware or software related. It will also clear up some of the notorious V. 1.0 OS bugs if your T-3 is running on that version of software.
  4. Blu bro

    Blu bro

    Mar 1, 2012
    thanks guys, i will try the reload. fingers crossed. i dont know of an authorised serviceman in Western Australia. But i will email Moog and see what they say. I know how much this thing was to get it shipped from America so i am not looking foward to it having to be shipped to be fixed. But alas i must do what i must do.

Share This Page