1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Carvin BX500 Mute Problem

Discussion in 'Amps and Cabs [BG]' started by Saint, Apr 19, 2018.


  1. Saint

    Saint

    Mar 2, 2000
    DC - USA
    I've had a Carvin BX500 for a few years now and have been very happy with it.
    However, I came home after being away for the weekend only to find that when I turn the amp on, the mute function is engaged regardless of whether the mute switch is on or off.
    Anyone have experience with this problem or -more importantly- how to fix it?
    Thanks!
     
  2. jeff7bass

    jeff7bass

    Apr 9, 2009
    When you press it, does the amp still work? Might just need a blast of De-Oxit.
     
    Saint likes this.
  3. BadExample

    BadExample

    Jan 21, 2016
    Injiana
    Saint likes this.
  4. Saint

    Saint

    Mar 2, 2000
    DC - USA
    Thanks @BadExample. Footswitch was plugged in. Will give it a try.
     
  5. Saint

    Saint

    Mar 2, 2000
    DC - USA
    Okay, I’m an idiot, but thank god for the TalkBass family. @BadExample hit it right on the nose: it was the footswitch. I only ever use one of the two buttons on the footswitch to engage/disengage the EQ curve, and that’s all I ever used it for on the older R600 I had before the BX500. I never even thought about what the other button does, but it apparently engages the mute. Duh. Really appreciate the help. IMG_5080.JPG
     
  6. Spidey2112

    Spidey2112

    Aug 3, 2016
    Saint and BadExample like this.
  7. BadExample

    BadExample

    Jan 21, 2016
    Injiana
    We're both idiots then, it got me :D
     
    Saint and Spidey2112 like this.
  8. Shhhhh! Don’t tell him that we’ll never live it down!!!

    :D
     
    Saint and Spidey2112 like this.

Share This Page