1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

Computer problem

Discussion in 'Off Topic [BG]' started by i_got_a_mohawk, Apr 19, 2009.


  1. Well, I've got questions on the boards of each manufacturer, but thought I would probe the computer savvy here.

    Had a few problems on and off with my computer which after a lot of questions, answers and such came down to being a problem related to the RAM.

    I have 4x 1Gb ram modules. I tested the modules individually using memtest for an extended period of time. Each module was fine. As soon as more than one module is installed, system stability goes to hell (memtest shows errors from the first run).

    Anyone have any ideas about this? The PSU I've got is good quality and should be more than enough power for the system. I've been told it is probably a motherboard issue, which would be a PITA :meh:
     
  2. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    what kind of mobo you running?

    edit(jt) : also, cpu and ram specs (type, speed, etc) plz.
     
  3. CPU - Intel Q6600
    Motherboard - ASUS P5K Premium (specs)
    RAM - 4x Corsair Dominator CM2X1024-8500C5D (DDR2 - 1066, 1Gb)
    Power - Corsair HX620

    Running XP-Pro, SP3 (I realise it wont get the full use of 4Gb, but have been told that shouldnt be an issue)

    As is typical, from googling earlier today, found quite a few problems with the motherboard and ram, though corsair stand by saying it should work.
     
  4. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    yeah, using xp is irrelevant - you'll be fine with 4 gig in, it just wont be able to address (use) it all.

    what revision of bios is loaded on your board?

    also, have you set the bus speed to correspond to your mem speed? the chipset you're using looks like it only natively supports the 800 mhz ram. you might have to manually boost the fsb speed to match the mem speed. the asus board apparently supports this higher speed, but you might have to manually set it in the bios.

    are you putting the ram in the appropriate slots? with two sticks in you might have to put the ram in alternate slots (i.e. if you have 4 slots on the mobo, you put the 2 sticks in slot 1 and slot 3.) the slots you should use for both ram sticks should match in color.

    some quick ideas - you probably thought of them already.
     
  5. Bios is ver 0404. Current version on the asus page is 1101. So I dare say that could do with being updated. But on saying that, there seems to be a lot of issues with the asus bios updates.

    I've not tried altering any speeds etc in the bios. Would the system not be able to run the ram at 800Mhz manually? (thought ram speeds could be rev'ed down?)

    I tried it both with one in each channel (slots 1&3 [yellow,yellow]) and with two sticks in one channel (1&2 [yellow, black]) and also with all 4 sticks in.

    p5k_premium_top.
     
  6. Looking through the improvements with BIOS revisions, version 0504, the one up from mine has "Enhance memory compatibility" listed. Worthwhile installing the newest revision or just go for that one?
     
  7. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    definitely update the bios before you do anything further. there are a slew of other issues that the bios update probably addresses that you might not even have bumped into yet, or are bumping into that are contributing to this issue.

    i know of the wonkiness of asus bios updates (my big cube monster computer had an asus board in it, and the bios shennanigans gave me fits for a week when i first started). not to mention asus manuals were generally crap. still, bios updates are there for a reason. often when the boards are developed they don't have time to really test hardcore test them before the cpu's they are supporting are released. early bioses on almost all boards really suck eggs big time. generally takes a half dozen releases before the boards are truly bulletproof, imo.

    as for modifying the speed - the fsb should be 533 to match the memory (i think it's doubled for that chipset, so 533 equates to 1066). it is probably 400 mhz standard. that -might- be the issue - i've never dealt closely with ram that fast. the slower stuff could usually "underachieve" when it was being driven by a slower bus (like in my cube comp, the 500 mhz ram would behave if i ran it at the board default 400 mhz speed, with no errors).

    but first things first. find the most recent stable, acceptable bios update and update it. seriously. at least to the 0504 one -s ounds like that's the ticket considering what you're saying it addressed.

    furthermore, i would definitely check out what each subsequent bios was addressing, and seriously consider updating to the most recent, barring any major outcries. there should be some very stable bioses out there for this, though - this chipset's been around for a bit.
     
  8. Cheers for the help :)

    It's now 2am, and this is a job for tomorrow.

    There's the asus update program that runs in windows to update the bios, but that seems to have been responsible for bricking quite a number of computers. So looks like the old fashioned way is required. Gonna have to format a USB pen for this.

    Here's a copy/paste of the BIOS history they provide. Will go with the newest, but don't think there has been much useful (to me) updates:

    =====
    [ 1101 ]
    ----------------------
    1. Support new CPUs. Please refer to our website at: http://support.asus.com/cpusupport/cpusupport.aspx
    2. Fix the display priority may be incorrect when plugging two PCIE VGA cards.



    [ 1001 ]
    ----------------------
    1. Fix a typo in French.
    2. Fix the system may hang at XP logo for 30 seconds when all USB ports are in use.



    [ 0901 ]
    ----------------------
    1. Fix the system may not be able to detect PROMISE RAID card.



    [ 0802 ]
    ----------------------
    1. Fix the system may show "Failed to flash!" in CrashFree.
    2. Fix Realtek Lan function may not function in Vista and WinXP when AI-NET2 is enabled then disabled in BIOS.



    [ 0702 ]
    ----------------------
    Support new CPUs. Please refer to our website at: http://support.asus.com/cpusupport/cpusupport.aspx



    [ 0612 ]
    ----------------------
    Improve ATAPI CD-ROM's compatibility with EZ-Flash.
    Support new CPUs. Please refer to our website at: http://support.asus.com/cpusupport/cpusupport.aspx.
    Add [7 DRAM Clocks] in [CAS# Latency] option.
    Add some items for [REF Cycle Time].
    Enable better support for FSB1600/DDR-1200 combination.
    Enable CPR support for CPU Ratio control.
    Fix C1E, TM and EIST can't be disabled issue.
    Add option [60 DRAM Clocks] into [REF Cycle Time] setup item.
    Fix when using Conroe 3.0GHz CPU with FSB1333MHz the system may not resume from S3.



    [ 0504 ]
    ----------------------
    1. Support new CPUs. Please refer to our website at: http://support.asus.com/cpusupport/cpusupport.aspx
    2. Enhance memory compatibility



    [ 0404 ]
    ----------------------
    1. Support new CPUs. Please refer to our website at: http://support.asus.com/cpusupport/cpusupport.aspx
    2. Enhance memory compatibility
    3. Fix EN7950GX2 can't work in CrashFree mode

    =====

    Cheers for the assist :)
     
  9. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    a further word about updating bios.

    the nice thing about asus is that the shipped bios is in rom on the board, so if worst comes to worst you can pop the battery and restore the original bios (or toggle a jumper, not sure on your board. battery always works, iirc). it should be spelled out in your manual.

    i actually had to really experiment with what bios i was going to use in my cube, because i was using the quad sli setup too, and there was just all kinds of crazy going on with the pci16's trying to talk to the two 7950gx2s.

    i ended up not using the most recent bios when my comp was actually built, but a few revisions earlier, because of certain powersaving crap they added ( :rolleyes: ) that, iirc, messed with the pci16 slots (i have no idea how). took a few months before they put out a bios that supported my system appropriately.

    the moral of the story is, experiment. get that early bios update - the 0504 - that discusses the expanded memory support. use 2 sticks that you are certain work to check (when it works for them, it will work for 4). put them in both yellow slots. make sure you configure the bios appropriately (get the bus speed to match the speed of your memory) and then see what happens. if you get it stable, you might want to consider just leaving it, or update the bios further.
     
  10. I'll give it a bash tomorrow. Cheers again for the help :)

    One thing I was wondering re-fsb speeds that you mentioned. If that was causing a problem, why would it only be causing a problem with more than one stick of ram on the motherboard?

    Cheers

    - W
     
  11. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    lol. looking at that list, it's like reading the same bios upgrades for my board from 2006. same wonky crap needing fixing months later. gotta love asus. they make sweet gear though.

    yeah, i would actually up the bios to 0612, tbh. the cas latency number and ref cycle time listed there tells me they were having issues with some of the faster ram. might be a thing of note. :)
     
  12. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    because of how the memory is used - in parallel. one stick by itself can just chug along at whatever speed.

    but with two, from what i understand they are interleaved, so if there's timing issues, things get ugly.

    like i said, slower ram is fine about this kind of thing, ime, but i have heard (vaguely, no expert on these boards by any stretch) that with faster stuff it can get kooky if it's not run at the speed it is rated at.

    tbh, though, a more likely candidate for these issues, imo, are what i see listed as being addressed in 0612 (cas and ref). thats ram related stuff right there, and it may be the root of the issue.

    definitely only use the two yellow slots if you only have 2 sticks in, though. at least, that's how i would do it.
     
  13. excane

    excane Banned

    Aug 23, 2005
    New York, NY
    I will suggest one more option....putting a memory switch in the boot.ini such as "/3GB"

    You can read about this on microsoft's site. It's solved several similar issues I had with my PC.
     
  14. One thing you may want to try is setting the memory timings and voltage settings manually in the BIOS. I had a similar problem with my last build. I would get random crashes and traced it back to the memory.

    Usually, by default the timings will be set to "auto" and I'll bet the voltage is set lower than what Corsair recommends for the Dominator series.

    Looking at New Egg your setting should be:
    Timing: 5-5-5-15
    Voltage: 2.1V

    You may want to double check it at Corsairs website.
     
  15. BIOS updated.

    Now the computer won't boot with more than one ram module plugged in :/ (ran memtest for 2-3 cycles with each module to check they are all still showing clear [was run for much longer than that initially] ).

    I'll try rolling back the BIOS version, had installed the newest version.

    Does this sound like it could be a hardware issue?

    FSB is sitting set at 266 and the RAM was set to DDR2-1066 in the BIOS. The timings are set to 5-5-5-15 and I changed the ram voltage from auto to 2.1v.
     
  16. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    imo this is definitely a bios issue. does it at least boot sufficiently to get to the title screen, where it says "hit tab to blah blah blah, hit f1 to enter setup"?

    try booting with a single stick in the other yellow slot, to make sure that slot is ok.
     
  17. I'll try booting in the other yellow slot.

    Didnt get anything, just no picture at all on the screen. Annoyingly (only bad thing I can think of about the case I have) is there is no piezo speaker, so I couldnt even register the beeps and google to figure out if it gives any indication as to the problem (also dont think there is any other way to check with this motherboard :( )
     
  18. Tried a stick in the second yellow slot and it booted fine.

    Added another stick in the first slot (same sticks as I tried earlier), and it booted. whiskey tango foxtrot?!

    Still to run memtest though. Will do it both with one stick in the second yellow slot and both sticks in (if that prior works fine).

    I get the impression this motherboard is mocking me . . .
     
  19. Final post for the night.

    Ran memtest with two sticks in. Only ran through once, but it passed (quite good since any other time testing with more than one stick it gave over 100 errors in the first run). It took quite a bit longer, but I guess that makes sense if there is more RAM in there to test. Will leave it to run for longer tomorrow.

    So looks like it was a BIOS issue, but I wonder why it went through a period of not loading up with two sticks in. Very strange . . .

    Will run memtest again tomorrow, for a longer period, then try it with all 4 sticks in. Fingers crossed :)

    Cheers again for all the help guys!

    (One thing that seemed wierd tho, in memtest it was saying the ram was only 401Mhz, and in brackets DDR802, the BIOS is set at 1066Mhz. Is this normal?)
     
  20. john turner

    john turner You don't want to do that. Trust me. Staff Member

    Mar 14, 2000
    atlanta ga
    no, for some reason your bios isn't upping the bus speed to match your memory. that's the issue i said earlier - the bus speed needs to match your ram speed.

    that might not end up being stable. if it doesn't you know why.

    what bios rev are you up to now?
     

Share This Page