Crappy SVTIII Pro

Discussion in 'Amps and Cabs [BG]' started by jbusbee87, Jun 23, 2003.

  1. jbusbee87


    Jun 23, 2003
    I need help. I have called Ampeg and had this thing in the shop twice. Changed all the tubes. I run a Cirrus 4 string into the head, it will Peak and cut out. It cuts in and out, not fading like bad tubes. It will also peak with no input; I can turn it on and the peak light will come on and stay. I am running it into an Ampeg Classic 410 w/horn. Another thing, I don't think this thing is very loud-it can't hang with me playing drums. I am ready to throw this thing away. Everyone I have called needs it to be sent to them for "exploration"...I can't afford to sent a 300 dollar head to be over hauled, it isn't worth it. I think the Carvin looks real nice....Thanks to anyone that can help
  2. rok51


    Sep 2, 2002
    Crawfordville, FL
    Get it fixed! Then bitch if you don't like it. Mine has been doing yeoman service since '94...I won't contemplate letting it go.
    Honestly, they are one of Ampeg's better new amps. Your problem is not typical and I believe you would pleasantly surprised with a III Pro that didn't cut out on you.

  3. Jeff Haley

    Jeff Haley

    May 17, 2001
    Atlanta, Ga.
    I owned one of those for a while and I found it to be a little underpowered. If you want a powerful and good sounding solid state amp try the GK 1001. It is loud and clear. I like these better than the Carvin and the Ampeg SVT pro-3. I have owned all of these amps before so I am speaking from my experience. Good luck.