1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Crate BX-2115 HELP NEEDED

Discussion in 'Amps and Cabs [BG]' started by HighCountry, May 17, 2011.


  1. HighCountry

    HighCountry

    May 17, 2011
    I have an old BX-2115 (http://www.crateamps.com/pdf/manuals/BX2115_OM.pdf)and I am having some trouble with it. (note I do not have the head, just the cab) The amp will turn on, lights will light up, but there seems to be no signal coming from the input. I have taken the head unit out of the cabinet and the connection for the input looks fine. Has anyone had a similar problem?
     
  2. thumpbass1

    thumpbass1

    Jul 4, 2004
    Try and jumper an instrument patch cable from the send of the effects loop back into the return of the loop and see if things fire back up again soundwise. If so, you have some internal oxidation going on in the effects loop and it needs cleaned by squirting some pot/tuner cleaner in there and working a jack in and out a few times. It's a common, yet often overlooked problem that occurs with St. Louis era Crate and some Ampeg amps, that causes the symptoms you have described. I'd start there first.
     
  3. HighCountry

    HighCountry

    May 17, 2011
    Thanks for a quick reply man, I'll give it a shot.
     
  4. seansvs

    seansvs

    Feb 1, 2011
    Sorry for the super delayed bump, but...
    What if that didn't work?

    The amp does produce some output, but is very quiet, and requires all volume and gain controls to be at max just to be heard. Then its all crackly and nasty, and not very loud at all :(
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.