1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Dark Star Pickup noise problem

Discussion in 'Pickups & Electronics [BG]' started by vinnydbass, Feb 16, 2008.


  1. vinnydbass

    vinnydbass

    Feb 4, 2008
    i just installed the dark stars into my jazz bass. they sound great except for when im resting my thumb on the metal casing, a hum appears. ive checked all my connections, and my grounding seems to be correct.


    wut can i do?
     
  2. raytsmith

    raytsmith

    Nov 21, 2007
    Central Ky
    Sounds like a grounding issue still...try running a jumper wire from the pickup surround to your bridge and see if it quits. If so, sounds like you'll need to open the control cavity and do some more soldering.

    Did you put in two Darkstars, and if so, get a hum from both of them when you touch 'em ?

    Both pickups, all of the pots, the output jack, and the bridge should all be connected together to a common ground. You can get some jumper wires with clips at Radio Shack fairly cheap and they will help you track down the loose ground.

    If this fails, try a different instrument cord, maybe the ground lift on your amp if it has one...

    Good Luck, hope you'll probably find the effort is well worth the DS tone...
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.