Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

demeter hummmmmmm

Discussion in 'Amps and Cabs [BG]' started by Andy Nelson, Jan 20, 2005.


  1. setup is:

    peavey cirrus -> demeter 201s -> crest LT2000 -> ampeg 410

    the lt2000 is very quiet when i plug in directy with bass. i've tried different cables too. seems as soon as demeter is in the mix i get hummmmmmm.

    what do you guys think?

    andy
     
  2. IvanMike

    IvanMike Player Characters fear me... Staff Member Supporting Member

    Nov 10, 2002
    Middletown CT, USA
    i think you may have a grounding issue
    if it is a defect in the demeter they should fix it.
     
  3. lo-freq

    lo-freq aka UFO

    Jan 19, 2003
    The Republic of Texas
    Try a two prong plug adapter at the end of the Dem's power cord (if you haven't already).
     
  4. i don't have one of these, a 3 prong to a 2 prong?
     
  5. Have you tried changing the ground/lift switch setting?
     
  6. bikeplate

    bikeplate Supporting Member

    Jun 7, 2001
    Upstate NY
    Hi!

    I have a demeter 201 with no issues. I set the volume on it just past 12 oclock and use the power amp as a volume. See if that works

    Rob
     
  7. i'm using the 1/4'' out, you think i should use the mic cable instead?

    andy
     
  8. the volume on the demeter has no effect of the humming volume that i hear. the volume of the amp only increases the hum that the demeter makes. hope that makes sense. :cool:
     
  9. I use the 1/4" into the power amp myself, and run the XLR to the mixing board. No hum either place.

    Have you always had this hum, or is it something new? Definately try the ground/lift switch....

    Mike
     
  10. i bought this item used from a member here on TB, i've messaged him about the issue, and he hadn't experienced anything like that when he owned it. he offered to help cover the cost of fixing it, what a gentleman! (thanks gruuv)

    i'm hoping its a grounding issue or something. heading to a music store today to try and play with a few more options.

    if thats not it, than it must have been dropped during shipping :bawl:

    andy
     
  11. jokerjkny

    jokerjkny

    Jan 19, 2002
    NY / NJ / PA
    try swapping out the tubes. could be a bad one.
     
  12. metron

    metron Fluffy does not agree

    Sep 12, 2003
    Lakewood Colorado
    I second that. I bought a new Demeter VTBP-201s and within a week or two the unit develpoed hiss and crackly static. It turned out to be the tubes. The dealer contacted Adam and I had a new set within the week. No problems since.
     
  13. smperry

    smperry Moderator Staff Member Gold Supporting Member

    Nov 3, 2003
    Bay Area, CA
    Endorsing Artist: Martin Keith Guitars
    So, did you try the ground switch in the back?

    Marshall
     
  14. good news guys, seems i've sovled it. turns out that my outlet/powerstrip was the culprit, furthermore a smaller instrument cable proved to make the humming almost inaudible. :hyper:

    thanks for all your help!!

    [​IMG]

    p.s. this thing is loud :cool:
     
  15. NIce pre, let us know how is sounds with that Crest..
     
  16. :hyper:
     
  17. hey big string, i have read a ton of your posts(thanks for contributing)

    had a question about your demeter, i know you traded out your tubes, just wanted to know about your results, where you grabed them, what type of audible changes did you experience ect....

    about the LT2000, i can't really say how powerful is to other power amps because its my first, but to me it seems VERY powerful, the settings that are shown in that picture rattle my apartment pretty good with my 410.

    later on i'm going to be looking into grabing some schroeder's cabs because i think the ampeg b-series 410 is kind of bland and too heavey for what it does (more like doesn't).

    cheers
    andy
     
  18. lo-freq

    lo-freq aka UFO

    Jan 19, 2003
    The Republic of Texas
    Glad you got it worked out.

    A Schro 410 with your rig would be awesome.

    I drive mine with a Dem 201S & PLX1602.
     
  19. Hi Spa, thanks.. it's nice to know I'm not boring everyone.. :cool: There is so much great information here at TB. I stopped reading the newspaper.

    Tubes.. let's see. When I had my Mesa 400+'s I had lots of tube time. I learned a few things and popped for NOS Telefunken Black-Smooth Plates 12ax7 glass. I decided on trying these tubes after looking for some Amperex Bugle Boys which is the first tube that caught my interest from reading here on the site and finding many links (very many). I couldn't name off all the knowledgable people that I learned a lot from here. Glad there are an impressive group of Tubies here on the site. Do some searches on 12ax7 and you'll come up with a lot. I did some reseach but there is a lifetime of information to 'really' know tubes.

    Anyway the 201s, as you know, has two tube sockets. I believe the left side is the volume and the right controls the tones. I'll have to look that up for sure. I am not sure I had to use both the NOS tubes and actually right now I have a new production JJ Tesla in the lefty. It sounds good with the JJ and the NOS Tele. NOS tube are expensive but they are hard copy. They are also more durable I've read and last a long while being taken care of properly. I can probably pm you some links on Monday.

    I'm having some trouble with my active input and I believe I'll have to send it in. Adam at Demeter told me to check the tubes but I belive it's a bad jack. But, I tried changing the left tube with the JJ and it does seem better so I hope it' not my NOS tube. The cutting in and out of the input tells me it may be both a bad jack and grouchy tube. :rollno:
     

  20. interesting... i didn't know that about the volume tube/tone tube.

    i hope you get your tube issue worked out. with my limited time with this preamp i've been very happy with it. its not very versitle(not my priority) but i do LOVE the tone(which is my priority :cool: ).

    waiting to try it out in a live situation, something i heard it execels in.

    big string please PM me those links, so much to learn in this place. :bassist: