Dismiss Notice

Psst... Ready to join TalkBass and start posting, make new friends, sell your gear, and more?  Register your free account in 30 seconds.

Digitech Bass Synth Wah problem

Discussion in 'Effects [BG]' started by SoComSurfing, Apr 30, 2004.


  1. SoComSurfing

    SoComSurfing Mercedes Benz Superdome. S 127. R 22. S 12-13.

    Feb 15, 2002
    Mobile, Al
    One of my students bought a used Bass Synth Wah, and is now having problems with the footswitch. He says sometimes it will either not turn on or off when the footswitch is pressed. Anyone have any suggestions as to a fix? I'll see it today when he brings it in, and will try spraying the switch with contact cleaner. Anyone have any other ideas?
     
  2. godoze

    godoze

    Oct 21, 2002
    i haven't had any problems with mine. the only thing i can think of is maybe he doesn't have the cover on properly; you have to take the cover off to replace the battery...just a thought.
     
  3. Corygma

    Corygma

    Feb 1, 2004
    My digitech compressor did the same thing when I first got it. It worked fine after I switched the battery. I'd try changing the battery first, before doing anything else to the pedal.
     
  4. supermonkey

    supermonkey

    Mar 15, 2004
    Atlanta, GA
    The batteries in it from the store will last about 30 minutes... so definitely check that out.
     
  5. Ace123

    Ace123

    Sep 25, 2002
    Rochester, NY
    that happens with my digitech flanger sometimes. Usually i just have to change the battery, they don't last very long at all...
     
  6. SoComSurfing

    SoComSurfing Mercedes Benz Superdome. S 127. R 22. S 12-13.

    Feb 15, 2002
    Mobile, Al
    OK, he brought it in to his lesson, and appearently he had an entire batch of Duracell batteries that were bad. I pulled a fresh battery out of the drawer and cleaned all the connections. Works like a charm now. Thanks guys!

    PS. We weren't as oblivious as to not check the battery, but neither of us figured that he would have an entire box on 9-volts that were all bad. ;)
     
  7. Let's see, I had problems with mine even with a new battery. Check to see that your spring is okay. If your spring is okay then I can't help. Hope this helps.