1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

DigiTech BP355 Issue

Discussion in 'Effects [BG]' started by Bcalhoun54, May 4, 2015.


  1. Bcalhoun54

    Bcalhoun54

    Aug 25, 2014
    Cypress, TX
    I have a DigiTech BP355. I'm having a problem and wanted to see if anyone else has encountered the same. There is no on/off switch so I have been leaving the unit on pretty much all the time. This morning when I went to practice, there was no sound from the DigiTech. I unplugged from the pedalboard and plugged directly into the amp. Everything was working fine without the pedalboard. Plugged back in and, nothing.

    Anyone had a similar experience with the DigiTech BP355?
     
  2. Crystalman85

    Crystalman85

    Nov 30, 2008
    Chicago, Il.
    I don't have that kind of issue when I've had the digitech bp355. were you using in manual mode or memory mode?
     
  3. NealBass

    NealBass Supporting Member

    Jun 19, 2014
    Ontario
    I'd try hitting both pedals on the left simultaneously. The Mute might be on. If not, reboot. If there's still nothing, try a factory reset (steps are in the manual).
    Good luck!

    PS: I plugged my old BP355 into a power bar with a switch on it. That way, I could turn it off.
     
  4. Crystalman85

    Crystalman85

    Nov 30, 2008
    Chicago, Il.
    Your digitech bp355 isn't defected is it? at one point, I have read some reviews saying that they were defected and had to order a new one. I don't know if it's true or not.
     
  5. NealBass

    NealBass Supporting Member

    Jun 19, 2014
    Ontario
    Yeah, mine has a bad foot-switch. Cheap plastic foot-switches that you can't change out, was my only real complaint with the BP355. I use it's big brother, an RP1000 now. It has metal vacuum switches, which work better and are replaceable, if they do go faulty. The RP also has a power switch on it. Yay!
     
  6. Crystalman85

    Crystalman85

    Nov 30, 2008
    Chicago, Il.
    Okay...the only trouble I've had with the digitech bp355 is that when using the drum machine, I couldn't use my patches. so instead, I use some random pre-set. which I find odd. and also the looper can be a little tough to use the looper. personally I don't use loopers, but one guy who was testing out the digitech bp355 when I was selling it had difficulties using the looper. I have no idea why. other than that, I had no trouble using the digitech bp355 when I had it.
     
    NealBass likes this.
  7. Crystalman85

    Crystalman85

    Nov 30, 2008
    Chicago, Il.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.