DOD Milkbox suddenly stopped outputting signal when bypassed

Discussion in 'Effects [BG]' started by MooThing, Nov 20, 2015.


Tags:
  1. So I got a 96 DOD Milkbox about 2 months ago, its been working absolutely fine. I didn't use my board for roughly a week and I go to turn on my amp and find no signal was flowing. I made sure my in/out gain was up past zero, I made sure my tuner was off and all of my pedals were working. My envelope, fuzz and chorus worked, but when I kicked on the Milkbox then the signal started flowing.

    I don't know how much I can say, obviously the switch is working, all my cables are fine, it's all being powered by a 1Spot so there could be a problem there (e.g. not enough power to drive the buffer or something), has anyone had a similar issue? I can upload pictures of the pedals guts if needed.
     
  2. lerxst_x

    lerxst_x

    Feb 8, 2013
    Haslet, TX
    I have the same problem on an old Iban ez CP9....works fine when engaged, no signal when set to bypass. Since it's a compressor I leave it on anyway, but it does make it a bit more difficult to dial in unity gain.
     
  3. Yeah, I don't play with it off (gotta get mah thump). It just really annoys me that it stopped working dry out of nowhere.
     
  4. gregmon79

    gregmon79 I did it for the muff... Supporting Member

    Dec 20, 2012
    Chicago IL
    It could be a power issue. Maybe. I noticed with that series of DOD pedals, for whatever reason, they get a little wonky at times with power issues. Have you tried it with a battery?

    I know I have a Bass Grunge and an FX25b that get weird when powered with a battery, like the light stays on when bypassed. The FX25b can sound downright staticy with a battery. But that could be because the battery is dying too. I guess my point is, try different things with the power. If that doesnt work, start asking around for a builder or a handy pedal guy to take a look and test it. It very well could have a problem inside. Old DOD pedals are by no means bulletproof ;) Hope you find out whats wrong!! I hate it when stuff like that happens.
     
  5. bongomania

    bongomania Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    The actual switch device underneath the spring under the footswitch can tend to get dirty, causing failures. Clean it out with some good contact cleaner like Caigs. Also check for any loose wires or suspicious solder joints near where the switch connects to the circuitboard.
     
    mpdd likes this.
  6. mpdd

    mpdd neoconceptualist

    Mar 24, 2010
    LA
    just had my fx90 cleaned and it's working again
     
  7. What a shame, my screwdriver isnt getting any purchase on the screws on the back, and my bigger set was lost since about a month ago. I'll take your advice as soon as I can.
     
  8. kcole4001

    kcole4001

    Oct 7, 2009
    Nova Scotia
    Having the same issue with the switch in the wah I bought Saturday.
    It's intermittent, so it's obviously the switch.
    Gettin' replaced soon as the parts show up.
     
  9. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Jul 26, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.