1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  
     
    TalkBass.com has been uniting the low end since 1998.  Join us! :)

EBS Multidrive not working

Discussion in 'Effects [BG]' started by Vosk, Dec 9, 2006.


  1. Hi

    I bought an EBS multidrive from Japan on ebay about a month ago and I've had a few problems.

    Firstly it just wouldn't turn on and didn't really pass any signal. This was just out of the blue after a few days. I figured out one of the battery terminals had disconnected from the circuit so I soldered it back on - problem solved.

    I just went to play some bass a week or so ago and the light turned on, seemed fine. However firstly it just distorted everything weirdly, whether it was on or off. I changed battery (can't remember exact sequence of events) and now all it does it pass signal. When its on, the light is on, but adjusting the drive, volume or distortion type doesn't have any effect. All I get is my clean signal.

    Before I take it to an electronics repair guy, any ideas :confused: ?

    Cheers
     
  2. Nils

    Nils

    Oct 9, 2006
    Stockholm, Sweden
    That sucks... Dunno what could be wrong, but can't you send it back? Hope it works out...
     
  3. Thanks. I don't have any warranty info on it, I have a pretty low serial number (sub-100) so I'm guessing its pretty old. Plus it would cost a lot to send back to sweden, so I'll trust this guy who lives near me.
     
  4. What he means is, sending it back to the guy who sold it to you on eBay. If it was described as being in good working order, then the seller has clearly breached eBay policy by not disclosing it's condition in the auction. However, by tinkering inside it yourself you might have lost any recourse you might have had.
     

Share This Page